Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Warning Light] Erratic dash warning lights
#1
Hi everyone does anyone have a wiring diagram for the instrument cluster warning lights as my dash lights have become erratic lately flickering on and off on switch on and also sometimes driving. Maybe loose connections or bad earth.
Regards
Baz

2005 Peugeot Partner 2.0 hdi quick silver same as M59.
Reply
#2
When you say warning lights flickering do you mean the little icons or the actual orange illumination lighting? There's only 2 plugs I'm sure on the back of the m59 cluster so it will be a dirty connection, worth just cleaning all the plug pins with alcohol and a cotton bud, then make sure the pins come all the way through the plug to the same height. If it's the dash illumination, try pressing and holding the dimmer button on the clocks (opposite one to the trip reset) till they dim fully down, then release and hold it till it goes fully bright again. Engine has to be running for this to work.

Have a look at this post below, might not have the bit you want, diagrams are a bit thin on the M59. I posted some years ago. Haynes would help, their diagrams are good on the Berlingos.

https://www.berlingoforum.com/thread-17165.html
______________________
Current:
2017 B9 1.6 BlueHDi Van
______________________
Previous:
2012 B9 1.6 HDi Van
2008 M59 1.6 HDi Van
2003 M59 1.9D Van
Reply
#3
Hi Zion.
Thanks for the reply it's the icons that are flickering . I will have a go at cleaning the pin pins as you suggest. Will give update soon. Regards Baz.
Reply
#4
Ok, does sound like a bad connection or a dry joint common to the whole display eh.
______________________
Current:
2017 B9 1.6 BlueHDi Van
______________________
Previous:
2012 B9 1.6 HDi Van
2008 M59 1.6 HDi Van
2003 M59 1.9D Van
Reply
#5
Hi
Did what was suggested and cleaned pins. When reconnected switched on and every icon lit up then all went off. I switched off ignition and waited for a few seconds then switched on again. This time all icons that are supposed to come on ie: Battery, oil, engine management, seat belt, air bags, etc all came on and went off as they are supposed to. The only one that never came on was the abs. This happened once before in my old posts. The last time this happened for some unknown reason the light mysteriously came on again and has been working as it should all this time until now. Now it seems I now have the same problem. Regards Baz.
Reply
#6
Could be a blown bulb...they're all just little tiny bulbs like Xmas tree lights. The bulbs are inserted in little twist and lock plastic holders.

Now I was right about the connections, just swap that holder and bulb with another one, if the dead icon moves, it's just a bulb. Go for the simple fix first. Don't over think it.
______________________
Current:
2017 B9 1.6 BlueHDi Van
______________________
Previous:
2012 B9 1.6 HDi Van
2008 M59 1.6 HDi Van
2003 M59 1.9D Van
Reply
#7
In the spare cluster I have, all the small warning lights are actually LEDs soldered to the PCB. May not be the case with all clusters of course.
Current: 2003 1.4i MS MPV - Lucifer Red
Prev: 2003 1.6 MS Desire - Blingo Blue
Reply
#8
Interesting mate, I'd have thought the M59 had wee bulbs like they use in the heating panel and illumination. SMD LEDs weren't so common 15 years ago.
______________________
Current:
2017 B9 1.6 BlueHDi Van
______________________
Previous:
2012 B9 1.6 HDi Van
2008 M59 1.6 HDi Van
2003 M59 1.9D Van
Reply
#9
Hi my cluster is defo lad's and not bulbs. Led must be ok because it came on after I cleaned the pins. And had been working before.
Reply
#10
Every day's a school day eh. Time to get your meter and soldering iron out then...
______________________
Current:
2017 B9 1.6 BlueHDi Van
______________________
Previous:
2012 B9 1.6 HDi Van
2008 M59 1.6 HDi Van
2003 M59 1.9D Van
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Stereo bongs lost
Last Post: OMG
Today 09:30 PM
» Replies: 9
» Views: 372
Billing battery draining
Last Post: paul1763
Today 09:09 PM
» Replies: 0
» Views: 9
Jacking
Last Post: Zion
Today 08:27 PM
» Replies: 16
» Views: 483
DPF additive pump fault
Last Post: John Bilko
Today 06:54 PM
» Replies: 24
» Views: 340
Wiring for 12vdc socket in load area
Last Post: John Bilko
Today 06:52 PM
» Replies: 23
» Views: 1044
B9 front footwell floor liner
Last Post: Zion
Today 05:24 PM
» Replies: 5
» Views: 78
Diesel in Oil?
Last Post: Tree
Today 03:31 PM
» Replies: 9
» Views: 143
B9 rear internal wheel areas
Last Post: Zion
Today 02:40 PM
» Replies: 5
» Views: 101
2003 Berlingo M59 DW8B no start
Last Post: Zion
Today 02:39 PM
» Replies: 29
» Views: 557
Eat8 1.5hdi stuttering and then stalled at traff...
Last Post: Zion
Today 02:26 PM
» Replies: 16
» Views: 365

[-]
Recent Visitors
Locations of visitors to this page

[-]
Hosting by

QuickHostUK