Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Horn / air bag light
#1
Hi all ,help please,recently the horn on my lingo has been working 50% of the time !! and ive noticed that the air bag light is on constantly on the dash ! to get the air bag light to go off in the past i used to fiddle with connector under drivers seat and it would go out!! but it won't go out now with that method !! so do you think that both problems are connected within the horn push ??? any input would be much appreciated thanks ,
Big Grin nice to be important,more important to be nice Wink
my ride is a berlingo forte 1.9d 2003 model
Reply
#2
Have you looked at the connections under the passenger seat?

My airbag light was on for about 5 years and I only addressed it when it became included in the MOT. On advice from this forum it turned out it was that.

I did think it may have been caused by my son's size 13s but it was more likely done by myself when I ripped out a CD multichanger that had been dealer fitted when I bought the car. I got tired of loading and unloading it with my head in the footwell.

Not sure the horn problem would be related but I've been wrong before. Apparently. According to my ex wives.

Good luck!
Reply
#3
Could be you have a new problem with wiring or earth connection in the steering wheel, where wiring for both that airbag and the horn are. Especially if the wiring under the seat seems fine on inspection.
Current: 2003 1.4i MS MPV - Lucifer Red
Prev: 2003 1.6 MS Desire - Bile Blue
Reply
#4
Thank you both very much ,i shall have a look at both suggestions,can you explain to me how to remove horn push ??? my steering wheel has the 4 spokes with no holes on the undersides !!!
Big Grin nice to be important,more important to be nice Wink
my ride is a berlingo forte 1.9d 2003 model
Reply
#5
Can't help on the steering wheel removal mate though others will know on the M59. Should be a hole to release the airbag. Might be two torx screws behind each side, not accessible till you turn the wheel 90 degrees.

Anyway, it could be a crack across the ribbon cable called the clock spring. That would cause the issues you have and needs the whole unit under the steering wheel replaced to cure it.
My Van: 2012 B9 1.6 HDi Enterprise
Reply
#6
Ok thanks mucker
Big Grin nice to be important,more important to be nice Wink
my ride is a berlingo forte 1.9d 2003 model
Reply
#7
This sort of helps... it'll also give your RD3 a workout too!

https://www.youtube.com/watch?v=rODXzl6uTBQ

Also....

https://www.youtube.com/watch?v=eTeJ5UIQKdo

https://www.youtube.com/watch?v=ULG_7_NOYVY
Current: 2003 1.4i MS MPV - Lucifer Red
Prev: 2003 1.6 MS Desire - Bile Blue
Reply
#8
Thank you very much indeed Rasputin i am very much obliged that you took the trouble to look for this information , unfortunately its all above me !! by the way what is RD3 ??
Big Grin nice to be important,more important to be nice Wink
my ride is a berlingo forte 1.9d 2003 model
Reply
#9
It's your stereo Gwyn.
My Van: 2012 B9 1.6 HDi Enterprise
Reply
#10
(Yesterday, 05:05 PM)Zion Wrote:  It's your stereo Gwyn.

Ok thanks Scott ,that goes to show my intelligence !!! haha
Big Grin nice to be important,more important to be nice Wink
my ride is a berlingo forte 1.9d 2003 model
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
New member here
Last Post: arcol
Today 06:53 PM
» Replies: 11
» Views: 413
Horn / air bag light
Last Post: my mucker
Today 06:36 PM
» Replies: 22
» Views: 1003
Battery drain
Last Post: Pitkin2020
Today 06:09 PM
» Replies: 16
» Views: 961
2003 1.9d 4 sale
Last Post: my mucker
Today 06:08 PM
» Replies: 1
» Views: 466
Loose air intake
Last Post: Zion
Today 03:59 PM
» Replies: 2
» Views: 258
Toolkit
Last Post: Zion
Today 03:57 PM
» Replies: 17
» Views: 2732
{SAGA} Timing snapped
Last Post: Zion
Today 03:54 PM
» Replies: 97
» Views: 13269
Berlingo type
Last Post: Zion
Today 03:50 PM
» Replies: 2
» Views: 117
[SOLVED] Won't start with remote fob (2003 2.0 H...
Last Post: benoliver999
Today 02:54 PM
» Replies: 14
» Views: 758
Hi
Last Post: cancunia
Today 02:53 PM
» Replies: 1
» Views: 168

[-]
Recent Visitors
Locations of visitors to this page