Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Coms2000
#1
Hi guys 
I'm new to the forum and picked up my berlingo 2004 1.9d lat year as a stop gap for my gardening business.
I am looking for a larger van now and now selling this. In the last few months the indicators only work when main lights are turned off?! Intermittently. I've been told it's a coms2000 issue does anyone have any idea on what to do with the fault

Many thanks
Reply
#2
(15-01-2022, 02:17 PM)Bukowski102 Wrote:  Hi guys 
I'm new to the forum and picked up my berlingo 2004 1.9d lat year as a stop gap for my gardening business.
I am looking for a larger van now and now selling this. In the last few months the indicators only work when main lights are turned off?! Intermittently. I've been told it's a coms2000 issue does anyone have any idea on what to do with the fault

Many thanks

Welcome to the forum.

As it is the 2004 it could be the DAV COM2000 unit, maybe or maybe not. If it is the DAV com2000 unit, then it is more than likely the end plastic buts for the indicators have worn out. It happens and it is common, if it is the DAV unit. If it is the DAV unit, you simply buy the plastic ends from ebay and replace them. There was a good video how to do it on youtube. I can find it if your unit is the DAV one.
If it is not the DAV unit, then it could be somewhat problematic column switch. I had a temporary solution to this (have a look at my threads: https://www.berlingoforum.com/thread-20412.html) with toothpicks. At the end, I bought a new com2000 unit from ebay, second hand and this fixed the problem. I think I paid ~£20-30.
Simply open the top part of the steering column and see what is written there, DAV com2000, Delphi, etc.
smile, you are alive!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Hope I don’t regret this impulse buy?
Last Post: JasonJ
Today 01:08 AM
» Replies: 0
» Views: 18
2013 Side Window Latch Missing Seal Washer
Last Post: brodfather11
Yesterday 08:43 PM
» Replies: 4
» Views: 557
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Zion
Yesterday 07:52 PM
» Replies: 1723
» Views: 584899
Berlingo Newbie
Last Post: Zion
Yesterday 07:46 PM
» Replies: 3
» Views: 416
1.6 hdi lumpy cold start - SOLVED!
Last Post: Zion
Yesterday 07:41 PM
» Replies: 117
» Views: 64640
"check engine" warning light
Last Post: Zion
Yesterday 07:33 PM
» Replies: 7
» Views: 609
1.6 petrol non-start
Last Post: saskak
Yesterday 04:27 PM
» Replies: 13
» Views: 1012
Boot jump/Conversion wanted
Last Post: Pointone
Yesterday 03:55 PM
» Replies: 0
» Views: 129
Berlingo (2008) Car Radio Diagram?
Last Post: Ian_99
20-01-2022 11:22 PM
» Replies: 9
» Views: 427
Underbody Rustproofing
Last Post: saskak
20-01-2022 09:08 PM
» Replies: 10
» Views: 763

[-]
Recent Visitors
Locations of visitors to this page

[-]
Hosting by

QuickHostUK