Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Blower motor not working
#1
I Hi all. Just purchased a 2003 multi space 2.0 diesel and one issue is the blower motor doesn’t work. When I move the dial, I can hear a clicking noise but nothing happens. Is this a common fault. Guess I need to remove blower and replace but any info appreciated. Thanks
Reply
#2
Have you tried all the fan settings? Does it work on the highest setting and none of the others?
Now an ex Berlingo owner, I have a C4
2010 (B9) Berlingo Multispace XTR HDi 112 - Kyanos Blue
Previously - 2002 (M49) Berlingo Multispace 2.0 HDi Diesel - Arctic Steel
Reply
#3
Hi. Thanks for your reply. No it doesn’t work on any settings.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Rear Caliper guide pins b9
Last Post: evdama
Today 03:36 PM
» Replies: 0
» Views: 7
Problem with Tyre Anti theft bolt
Last Post: evdama
Today 03:27 PM
» Replies: 8
» Views: 102
Part no please
Last Post: photosavage
Today 12:24 PM
» Replies: 2
» Views: 88
Size envy.
Last Post: ossian
Today 10:51 AM
» Replies: 14
» Views: 574
Rip off van servicing
Last Post: ffrenchie
Today 08:56 AM
» Replies: 6
» Views: 441
door chanel/seal
Last Post: RattyCortina
Today 08:45 AM
» Replies: 1
» Views: 51
intermittent right indicator problem
Last Post: Multispacer
Yesterday 09:32 PM
» Replies: 2
» Views: 88
The creation of my personal solo-travellor.
Last Post: EM58
Yesterday 05:55 PM
» Replies: 4
» Views: 239
An alternative to Diagbox - Topdon Artidiag 800B...
Last Post: Antdad
Yesterday 03:57 PM
» Replies: 23
» Views: 581
Identifying Electrical Fault :-( Work Around Adv...
Last Post: shtu
Yesterday 10:13 AM
» Replies: 3
» Views: 147

[-]
Recent Visitors
Locations of visitors to this page

[-]
Hosting by

QuickHostUK