Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Front Wipers Not Wiping
#1
2011 Berlingo First 1.6 HDI
Front wipers not working. Stopped working while driving, not the first time they stop working. Everything else seems to work.
When wipers worked we parked the car for a month and forgot to disconnect the battery. It was completely flat after a month so we recharged and connected it back. Wipers didn't work anymore. Parked for a month with battery disconnected, connected the battery and wipers worked! While driving wipers stopped wiping and parked. Wipers either worked or didn't, no weird activity ever.
Since they parked exactly where they're supposed to be (I have it marked on the windshield) I assume the motor, parking switch, fuses and relays are good. Relays are not clicking. Reset procedures found on youtube do not seem to help.
Are Haynes wiring diagrams correct? It shows 11Gr connector at steering wheel switches in Wash/wipe diagram so it should be like an 11 pin grey connector? Where's that? I only recall 6 pin grey and brown connectors.
I've read that on some cars wipers get disabled when bonnet is up. I think the switch is disconnected or whatever that was, not sure where the cable is but can bonnet switch disable wipers on berlingo?
Reply
#2
Here is the official Citroen schematic along with connector locations.

.pdf   M59_Wash_Wipe.pdf (Size: 702.48 KB / Downloads: 22)

5015: Windscreen wiper motor
1620: Vehicle speed sensor
1320: Engine ECU
5100: Windscreen wash pump
CV00: Controls under the steering wheel
PSF1: Engine bay fuse box
BSI1: Multiplexer

CV00 is a 6 pin grey connector. (6V NR = 6 pin GRey)

Colour codes:

.pdf   wiring legende.pdf (Size: 73.44 KB / Downloads: 9)
______________________
Current:
Not a Citroen!
______________________
Previous:
2017 B9 1.6 BlueHDi Van
2012 B9 1.6 HDi Van
2008 M59 1.6 HDi Van
2003 M59 1.9D Van
[-] The following 1 user says Thank You to Sol for this post:
  • SinsBird
Reply
#3
Thank you. I wanted to check if a signal is coming from controls, but I guess I will simply solve the problem with a good ol' wipers relay.
Reply
#4
Yeah the problem you have is the controls go to the BSI and it then in turn, operates the wiper motor. That rules out chucking a relay in unless you want to get creative with separate switch wiring.

What I would say to check, is pull the fuses in the main engine bay box and check the tags are clean & bright, another member on the forum had a nightmare getting something to work and it turned out the fuse blades were oxidized, and all needed cleaning, at which point everything worked again.

The could explain it not working after sitting for a while, and maybe a jolt caused it to work again, and then oxide took over. Low voltage connections are plagued by connectivity and oxidized pins.
______________________
Current:
Not a Citroen!
______________________
Previous:
2017 B9 1.6 BlueHDi Van
2012 B9 1.6 HDi Van
2008 M59 1.6 HDi Van
2003 M59 1.9D Van
Reply
#5
I noticed in the circuit diagram that the coils of the wiper relays are connected in series so if the first coil is not making contact, the second relay also won't work. I think I will split the BSM to see what's inside, test the relays.
Reply
#6
Since the provided wiring diagrams differ from haynes I decided to test a spare wiper motor with a multimeter. Turns out haynes is correct and the other diagram is wrong O.o Park signal wire is being pulled straight to ground through the parking switch.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Part Number(s) Help Please?
Last Post: GregS
Today 08:54 PM
» Replies: 1
» Views: 38
Heavy clutch which clutch cable to buy
Last Post: MCVITIE420
Today 08:48 PM
» Replies: 0
» Views: 20
Do you need spares? My van is leaving me.
Last Post: GregS
Today 08:30 PM
» Replies: 2
» Views: 52
Replacement Cigar Lighter Socket Help.
Last Post: axxeman
Today 05:17 PM
» Replies: 10
» Views: 307
2006 M59 1.9D panel van - spares or repair.
Last Post: GregS
Today 01:50 PM
» Replies: 0
» Views: 36
Dash lights: ? & ⚠️ ……. & 011. Ok
Last Post: evdama
Today 12:39 PM
» Replies: 2
» Views: 92
New forum user 1200 rpm diesel knock
Last Post: geoff
Today 08:14 AM
» Replies: 3
» Views: 104
AC not blowing cold air
Last Post: Pauluco
Yesterday 05:47 PM
» Replies: 10
» Views: 393
Aircon compressor left the chat !
Last Post: MisterD
Yesterday 05:38 PM
» Replies: 0
» Views: 34
New member introduction
Last Post: brodfather11
Yesterday 06:14 AM
» Replies: 3
» Views: 114

[-]
Recent Visitors
Locations of visitors to this page

[-]
Hosting by

QuickHostUK