Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Steering & Suspension] Windscreen washer problem
#1
Probably because of the freeze and me trying to use the washers but now not working. Cannot see where pipes go. Any thoughts or should I take it to the garage?


Sent from my iPhone using Tapatalk
Reply
#2
Happened to me a week ago, I'd blown the fuse (10amp), it's located under the bonnet passenger side No-3 in the fuse box, quite a few have had the same problem this year.
Hope that's your problem it's an easy fix.
[-] The following 1 user says Thank You to Onion_Bhaji for this post:
  • Jeffree
Reply
#3
The pump is mounted on the water bottle, deep down in the drivers side arch, ahead of the wheel well (i.e. behind the bumper area)

It could have gone if the fuse is not the issue. Many people have the problem and it's not the fuse, been there myself.
______________________
Current:
Not a Citroen!
______________________
Previous:
2017 B9 1.6 BlueHDi Van
2012 B9 1.6 HDi Van
2008 M59 1.6 HDi Van
2003 M59 1.9D Van
[-] The following 1 user says Thank You to Sol for this post:
  • Jeffree
Reply
#4
best is to not use washer until the temp is high and the ice inside the reservoir will melt, then it will work again, it happened to me on old Tractor Smile
it's not needed to replace the fuse
Peugeot Partner Tepee 1.6 BlueHDI 100, year 2017
If you like gaming visit GameForest
Reply
#5
Where do
I begin[Image: 0c3ef5a6331310fd152edf2e886a66cf.jpg]
[Image: cb0b42fc41e96e0933bab032d9283462.jpg]


Sent from my iPhone using Tapatalk
Reply
#6
Ok got the wrong fuse box. Didn’t know there were 2


Sent from my iPhone using Tapatalk
Reply
#7
Here are the fuse layouts for both (the one in your pic is the BSI)
   
   
   
   
______________________
Current:
Not a Citroen!
______________________
Previous:
2017 B9 1.6 BlueHDi Van
2012 B9 1.6 HDi Van
2008 M59 1.6 HDi Van
2003 M59 1.9D Van
Reply
#8
[Image: 1270e4592aeb8278a2f9ad17878334db.jpg]
So here is the fuse box. 3 seems to be the small red one bottom right but it is different from all the other 10amp fuses. In my car this one has a nipple on the top


Sent from my iPhone using Tapatalk
Reply
#9
That's an aftermarket fuse if it's a shot of your fusebox. Some do look different. Question is, has it blown or not.
______________________
Current:
Not a Citroen!
______________________
Previous:
2017 B9 1.6 BlueHDi Van
2012 B9 1.6 HDi Van
2008 M59 1.6 HDi Van
2003 M59 1.9D Van
[-] The following 1 user says Thank You to Sol for this post:
  • Jeffree
Reply
#10
Thank you everyone. I imagine it was replaced before. As the fuse looked very different to the rest. I replaced it with one of the spare 10amp and now the washers are back to working order.


Sent from my iPhone using Tapatalk
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
So long and thank's for all the fish!
Last Post: brodfather11
Today 04:30 PM
» Replies: 1
» Views: 41
newbie here
Last Post: Mackem3
Today 09:49 AM
» Replies: 0
» Views: 25
Non start , turns over
Last Post: Multispacer
Yesterday 12:20 PM
» Replies: 1
» Views: 85
Looking for breakers with Petrol M59
Last Post: Multispacer
Yesterday 10:29 AM
» Replies: 1
» Views: 69
MyCitroen App
Last Post: Blakey
Yesterday 08:01 AM
» Replies: 8
» Views: 433
Whats the S for? 19oC/19oC S
Last Post: Hughzie
26-05-2024 04:33 PM
» Replies: 2
» Views: 137
What does a service consist of ?
Last Post: StarFish
26-05-2024 01:46 PM
» Replies: 2
» Views: 105
Ad blue use age
Last Post: curlywurly1971
26-05-2024 08:46 AM
» Replies: 0
» Views: 79
Air con re gas
Last Post: shtu
25-05-2024 06:24 PM
» Replies: 1
» Views: 80
Free undertray for 2011 multispace
Last Post: needsmust
25-05-2024 10:44 AM
» Replies: 0
» Views: 46

[-]
Recent Visitors
Locations of visitors to this page

[-]
Hosting by

QuickHostUK