Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Faulty auto gear box or fake news?
#1
vehicle:- BERLINGO M-SPACE VTR E·HDI S-A from 2015

My automatic 2015 Berlingo has come up with "Gearbox Fault" on two occasions - both times after motorway driving for over an hour. First sign of trouble was the cruise control stopped responding then the warning and the vehicle is stuck in 1st. Seems like limp mode? - Might be able to change up with the flippers but I forgot which one is up and which is down.

Stop by the road for a few minutes and things were then OK for a bit. Got home and since then short trips (20min or so) and no messages.

Went to a garage to get the diagnostics, no faults at all.

Apart from taking breakdown cover has anyone any suggestions?

I have diagbox  that used to work but it now refuses to ever recognise the interface - suspect I do not have the correct drivers installed but can not sort it out.
Reply
#2
Maybe the gearbox is getting too warm / hot? Can you check or change the oil?
Reply
#3
Here is a link to a working VM of DiagBox v7.57 (the best version for coding) with the drivers already installed, which should work on your vehicle - if it cannot recognise the gearbox ECU then post back and I'll post up v9.68 which will work for diagnostic codes (global scan) but that one cannot do much in the way of coding. The fact you already have an interface for Diagbox is good as it only works with the Actia / Lexia interface and not with generic OBD ones.

It should be enough to get you codes for the gearbox as nothing else will be able to. Needs VMWare Player to run it. 2015 is borderline between v7 and v9 of Diagbox.

Diagbox 7.57 (VM version for use in VMware Workstation Player on any device)
https://mega.nz/file/exFmyDKJ#lwG4aSW9fY...FuU6mYuR7c
______________________
Current:
Not a Citroen!
______________________
Previous:
2017 B9 1.6 BlueHDi Van
2012 B9 1.6 HDi Van
2008 M59 1.6 HDi Van
2003 M59 1.9D Van
Reply
#4
Thanks Zion, downloaded the software and am playing with it, not managed to get past the validify page.

Meanwhile I have thought about toping up the automatic gear box fluid, is this possible? If so is there a guide anywhere? All I can find is for the manual gear box oil change.
Reply
#5
It's not an actual automatic gearbox, Citroen don't have one. It's a manual gearbox with a piloted clutch and gear shift. So it's really unlikely the oil is the issue - probably the control side is the problem, or the clutch itself.

I should have said, you have to use the VMware Player menu to pass control of the USB Actia interface over to the VM.

Player > Removable Devices > Actia interface (or what ever it refers to as the Lexia unit) and select it. From memory it may ask if you want to send that device to the VM every time it's connected, say yes.

Remember to have NO connection to the internet while running the software and cancel the menu asking to validate the software, just click no to check for updates etc and it should load.


Attached Files Thumbnail(s)
   
______________________
Current:
Not a Citroen!
______________________
Previous:
2017 B9 1.6 BlueHDi Van
2012 B9 1.6 HDi Van
2008 M59 1.6 HDi Van
2003 M59 1.9D Van
Reply
#6
Thanks Zion, I will have another play over the week-end.
Reply
#7
I think I am going to have to admit defeat.

I have downloaded the VM of DiagBox v7.57 - reach activation and select the X and the screen goes blank. Try the tick and get no internet.

I have used Oracle VM virtualbox seting up XP and installed Diagbox up to v7.57. Starts fine and I can give my VIN and get to "please connect a VCI" but can not get any further.

I have tried re-installing everything, even a clean install of Windows 10

In both systems I can not see the PSA interface to attach it to the host (used removable device on VM and the USB connections on VirtualBox)

I think that I do not have the Windows 10 driver to see the USB Actia interface - using device manager there is no actia entry. I have tried a number of possible ideas, I think I should be using a set of files vcommusb.inf vcommusb.sys, vcommusb.pnf and vcommusbamd64.cat -- installing the inf file I get operation completed successfully, but nothing works.

I also tried the program "setup Drivers Diagbox.exe" - it says the drivers have been set up on my computer.

Anyone any suggestions as to what I am doing wrong or how to get Windows 10 on the host to recognise the interface?
Reply
#8
I installed it on native windows 7 and it worked, lately I've used a windows 7x32 VM on windows 10 x 64 bit and it just worked, the interface was there when I passed it to the VM. Stupid question, you are trying this with the interface plugged in to the usb? Also I never use XP for Diagbox, always Windows 7 x 32 bit VMs and I've never had an issue.

If it's not plugged in, it won't show up at either end. And it does not need the drivers installed on the host computer, just plug it in, run the Diagbox VM, then use the menu in VMWare Player to connect the usb device from host to VM

"Connect a VCI" means the interface is not connected of course. Does it even show up in Windows 10 device manager as an unknown device or something with no driver installed? Plug it in, right click the windows 10 start button, click "device manager" and have a look.

If it isn't showing up, you need to solve that first. Or it won't work on the VM.

Did it ever ask to update the firmware when you used it previously, like on version 7.83 of diagbox? You could have bricked it if you did the update firmware, with a Chinese interface clone. It doesn't work and will brick the interface permanently.
______________________
Current:
Not a Citroen!
______________________
Previous:
2017 B9 1.6 BlueHDi Van
2012 B9 1.6 HDi Van
2008 M59 1.6 HDi Van
2003 M59 1.9D Van
Reply
#9
No, the interface does not appear in device manager. I re-installed Windows 10 to see if that made any difference but it didn't. I did see something with Actia there about a month ago but can not get it back after I re-installed Windows 10.

As far as I know I have not tried to update the interface but your thought could be the answer. In the past (a few years back) the interface worked but now it doesn't. Sort of sounds like I have bricked it. All I know is the green light comes on, flashes 3 times then stays on steady.

I have been trying it on two computers, a dedicated portable and my desktop, both with the same result.

Are the vcommusb files to install the driver on Windows 10 or are they for the XP Win7 on VM?

I will go away and try with Windows 7. Thanks again.
Reply
#10
After hours of testing I found that the USB to the interface lead is faulty, I can now contact the car. I'm using diagbox V7.74

The fault messages I get are
BSI - code F6FF unrecognised re-initialisation fault
Engine management ECU - P0504 brake pedal. This re-appears after clearing the fault.
Gear box not recognised. - When I select the CFC300P it says no fault. If I select the BNMP MCP UDS I get Comms error so I assume I have the CFC300P gearbox

I did previously have the fault P171A that I cleared but it has not re-appeared. I gather that is something to do with the automatic Gearbox, maybe the change from 3rd to 4th?

The gear change is sometimes very sluggish and I have had Gearbox Fault on the radio display a couple of times but then the car gets over the problem and things go normally.

A worrying fault but is seems that nothing can be done until it all fails!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Newbie owner
Last Post: RetroGirl67
Today 04:46 PM
» Replies: 5
» Views: 151
Engine won't start when hot
Last Post: racey83
Today 04:35 PM
» Replies: 3
» Views: 47
Hello Thinking of Getting a 5 seat Berlingo
Last Post: graceland
Today 03:49 PM
» Replies: 0
» Views: 24
AdBlue Remap Question
Last Post: Multispacer
Today 03:11 PM
» Replies: 4
» Views: 58
ABS light, No Speedo, Loss of Power. Can anyone ...
Last Post: Multispacer
Today 03:10 PM
» Replies: 9
» Views: 200
Starting conversion. Feel free to fling advice t...
Last Post: Divechick
Today 12:08 PM
» Replies: 0
» Views: 22
ABS light comes on with a beep
Last Post: Multispacer
Today 09:44 AM
» Replies: 1
» Views: 38
Trailer Electrics - Fuses (2019 Van)
Last Post: uk_friendly_fire
Today 09:27 AM
» Replies: 7
» Views: 141
Berlingo B9 AC problem
Last Post: igli
Today 09:05 AM
» Replies: 2
» Views: 62
Locked car while driving.
Last Post: jtr rhyl
Yesterday 04:42 PM
» Replies: 11
» Views: 315

[-]
Recent Visitors
Locations of visitors to this page

[-]
Hosting by

QuickHostUK