Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
2.0hdi brake servo problem
#1
Hi, 

I'm new to the Berlingo and the forum.

Have owned a 2002 Berlingo 2.0 Hdi for a few months which came with no history.  Last weekend the brakes semi-failed in a strange way.   With the engine running the brakes feel fine for the first couple of presses then the pedal goes hard as it would if the engine is off.  After a while it recovers and I get a couple more presses with assistance before it goes solid again.

Maybe related, the exhaust makes weird noises, like there is a leak but this seems to go away when accelerating.  There isn't any turbo boost as far as I can tell.  

Thanks in advance.
Reply
#2
Check the vacuum pump, and any vac hoses such as the main one to the brake servo drum. You have a vacuum leak somewhere of course.

Diesels have no vacuum at the intake since they have no throttle butterfly like a petrol, and need a working vacuum pump and a reservoir to hold that vacuum. Find that, and check all hoses coming from it. This is also how the turbo boost is controlled. They will all be related.

Splits on hoses tend to be near clamps or clips, and underneath where oil can collect when dripped or sprayed, also engine heat affects the bottom of hoses more than the top (since heat rises up from below) so look at these areas.

Service history is irrelevant for a fault, because faults stem from failed components and the failed items are not always "service items" which are checked during the service procedures.
______________________
Current:
Not a Citroen!
______________________
Previous:
2017 B9 1.6 BlueHDi Van
2012 B9 1.6 HDi Van
2008 M59 1.6 HDi Van
2003 M59 1.9D Van
Reply
#3
(10-05-2023, 12:36 PM)Zion Wrote:  Check the vacuum pump, and any vac hoses such as the main one to the brake servo drum. You have a vacuum leak somewhere of course.

Diesels have no vacuum at the intake since they have no throttle butterfly like a petrol, and need a working vacuum pump and a reservoir to hold that vacuum. Find that, and check all hoses coming from it. This is also how the turbo boost is controlled. They will all be related.

Splits on hoses tend to be near clamps or clips, and underneath where oil can collect when dripped or sprayed, also engine heat affects the bottom of hoses more than the top (since heat rises up from below) so look at these areas.

Service history is irrelevant for a fault, because faults stem from failed components and the failed items are not always "service items" which are checked during the service procedures.

Thanks for the reply.   Is the vacuum pump driven by the alternator belt or from a shaft?   Also, could this be why there doesn't seem to be any boost?
Reply
#4
It's driven off the cam with a dog drive end, there are seal kits on eBay for them too. Yes that could be why you have no boost - but are you certain there's no boost? You cannot hear the turbo spooling on most of these. It has a baffle / resonator on the outlet.
______________________
Current:
Not a Citroen!
______________________
Previous:
2017 B9 1.6 BlueHDi Van
2012 B9 1.6 HDi Van
2008 M59 1.6 HDi Van
2003 M59 1.9D Van
Reply
#5
(10-05-2023, 04:04 PM)Zion Wrote:  It's driven off the cam with a dog drive end, there are seal kits on eBay for them too. Yes that could be why you have no boost - but are you certain there's no boost? You cannot hear the turbo spooling on most of these. It has a baffle / resonator on the outlet.

Interesting - there’s no lag and it’s really slow so I assumed no boost.   The noise it a bit crazy, it’s like a blown exhaust that modulated by load so sometimes it’s quiet.
Reply
#6
Is it a 1.9d or a 1.6 HDi? The 1.9 has no turbo at all and is deathly slow but reliable.

If you have crazy noises coming from the exhaust, then you have problems and may be better to seek the help of a garage who know what they are doing.
______________________
Current:
Not a Citroen!
______________________
Previous:
2017 B9 1.6 BlueHDi Van
2012 B9 1.6 HDi Van
2008 M59 1.6 HDi Van
2003 M59 1.9D Van
Reply
#7
(12-05-2023, 07:00 AM)juliromero Wrote:  A mi me pasa lo mismo en el escape, ayuda por fa

Can you please use only English - we are an English site and no other language is supported. 

En Español: 
(¿Puede usar solo inglés? Somos un sitio en inglés y no se admite ningún otro idioma. No volveré a usar el Español después de esto. Gracias.)
______________________
Current:
Not a Citroen!
______________________
Previous:
2017 B9 1.6 BlueHDi Van
2012 B9 1.6 HDi Van
2008 M59 1.6 HDi Van
2003 M59 1.9D Van
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Boot/tailgate won't open - handle doesn't releas...
Last Post: benoliver999
Today 01:05 PM
» Replies: 2
» Views: 87
Locked car while driving.
Last Post: jtr rhyl
Today 05:46 AM
» Replies: 9
» Views: 283
ABS light, No Speedo, Loss of Power. Can anyone ...
Last Post: ThomasTheTMC
Yesterday 08:31 PM
» Replies: 6
» Views: 148
Very brief warning light
Last Post: Mark604
Yesterday 03:20 PM
» Replies: 1
» Views: 62
Trailer Electrics - Fuses (2019 Van)
Last Post: Paperstone
Yesterday 08:52 AM
» Replies: 6
» Views: 117
Removing sticker residue
Last Post: geoff
Yesterday 08:29 AM
» Replies: 12
» Views: 398
Identify a part
Last Post: mpj29201
Yesterday 06:23 AM
» Replies: 0
» Views: 58
ET18 and ET44 road wheels
Last Post: smutts
18-05-2024 07:50 PM
» Replies: 1
» Views: 124
1.6 petrol Multispace battery isdue.
Last Post: geoff
18-05-2024 07:22 PM
» Replies: 3
» Views: 141
Intro / Model
Last Post: Multispacer
18-05-2024 06:17 PM
» Replies: 1
» Views: 63

[-]
Recent Visitors
Locations of visitors to this page

[-]
Hosting by

QuickHostUK