Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Coolant temperature & pressure
#1
Hello all!

53 plate 1.9D multispace. Coolant/stop alarm keeps going off, resetting, going off, staying in, etc. Engine temperature is fine.  Seems like there may be an issue with the sensor?

However. Coolant levels are a bit all over the place as well. After a drive the coolant level is pushed down below the minimum line. I'm sure I'm loosing coolant from somewhere as well but no obvious leak. No exhaust smoke, no coolant in oil either. I changed the expansion tank cap but no change (except it goes on easier than the last one!)

Any ideas?
Reply
#2
When you say the coolant level is pushed down after a drive, do you mean it's gone down and stays down, or it rises back up again later?  Also what's the temperature gauge doing while all this is occurring?
Work van:     2020 1.5 BlueHDi 100 Enterprise Berlingo
Spare van:    2001 1.9 600d Berlingo
Reply
#3
(05-06-2023, 08:45 PM)notsofast Wrote:  When you say the coolant level is pushed down after a drive, do you mean it's gone down and stays down, or it rises back up again later?  Also what's the temperature gauge doing while all this is occurring?

Hi,

So this morning I find the coolant level on the minimum. I release the ET cap and it's under pressure. Bubbles up to the max line. Gone for a two mile drive this AM.  

Upon leaving my house the coolant/stop light has come on and stays on for a minute or so. Then off, then on again, a few times during the drive. Staying mostly on though.  During this time the temperature has only gotten to 75 degrees.  And daily my temperature never exceeds 90 and behaves normally the whole time. 

I check the coolant level on my return and it is about 2cms below the minimum line. I'll check later to see if it's come up again.
Reply
#4
Could be an air-lock.

Just run it with the cap off the expansion bottle for a while and see if it burps air out. Replace with coolant so its on the MIN when cold and MAX when hot. Check the de-gas pipe from the expansion bottle is clear and not blocked.

There is a prong-shaped level sensor on the expansion bottle too. It can be gummed up with crap, we have another member (@my mucker) who had exactly that issue. Just needed removed and cleaned up.
______________________
Current:
Not a Citroen!
______________________
Previous:
2017 B9 1.6 BlueHDi Van
2012 B9 1.6 HDi Van
2008 M59 1.6 HDi Van
2003 M59 1.9D Van
Reply
#5
(05-06-2023, 05:47 PM)Will1713 Wrote:  Hello all!

53 plate 1.9D multispace. Coolant/stop alarm keeps going off, resetting, going off, staying in, etc. Engine temperature is fine.  Seems like there may be an issue with the sensor?

However. Coolant levels are a bit all over the place as well. After a drive the coolant level is pushed down below the minimum line. I'm sure I'm loosing coolant from somewhere as well but no obvious leak. No exhaust smoke, no coolant in oil either. I changed the expansion tank cap but no change (except it goes on easier than the last one!)

Any ideas?

I had a similar message. Temperature gauge shot uo to full scale in a couple of seconds, and the STOP message showed up, on my 2005 2.0 HDi. Coolant level was fine. Temperature normal. I replaced the temperature sensor but it made no difference. 

I wondered if the problem was with the ECU. I removed each of the multi pin connectors, 3 of them, and cleaned them and their sockets thoroughly with a small paint brush. I then lightly sprayed them with an electrical contact spray. The problem has not returned since (over 2 years ago)

Might be worth a try.
Reply
#6
Sounds super likely to be an airlock issue. You can always take out the sensor and check its functionality with a multimeter. The resistance curves at set temperatures are usually available. Use a thermometer, but water out of the kettle is typically 80C and ice water is around 0C. You can use those two points and ensure its working rather than wasting money on a new sensor if it works.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
99bhp & 128bhp same engine?
Last Post: notsofast
Yesterday 09:42 PM
» Replies: 3
» Views: 54
Whats the S for? 19oC/19oC S
Last Post: evdama
Yesterday 07:08 PM
» Replies: 1
» Views: 68
Wind noise at speed
Last Post: StarFish
Yesterday 04:14 PM
» Replies: 16
» Views: 1383
Can MAF Sensor cause multiple faults and poor st...
Last Post: Bizzy9
Yesterday 04:12 PM
» Replies: 0
» Views: 28
ABS light comes on with a beep
Last Post: Multispacer
Yesterday 10:16 AM
» Replies: 3
» Views: 89
Identify a part
Last Post: Drummond
23-05-2024 05:53 PM
» Replies: 1
» Views: 99
Locked car while driving.
Last Post: Drummond
23-05-2024 05:45 PM
» Replies: 12
» Views: 426
Multispace Seats Flair 69 plate for sale
Last Post: Gollycrush
23-05-2024 04:31 PM
» Replies: 0
» Views: 50
ABS light, No Speedo, Loss of Power. Can anyone ...
Last Post: shtu
23-05-2024 02:28 PM
» Replies: 14
» Views: 374
Rear Tailgate wont unlock/open
Last Post: bradwebb
23-05-2024 01:56 PM
» Replies: 0
» Views: 48

[-]
Recent Visitors
Locations of visitors to this page

[-]
Hosting by

QuickHostUK