Thread Rating:
  • 6 Vote(s) - 2.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Help !
#1
Hi guys, I really need some advice if anyone can help me please. I have a 98 plate 1.9d which was running fine until a few days ago. It started to take more effort to start and then finally today it just wouldnt start after several attempts. After seeking advice from a friend I have now changed the glow plugs but it still is the same. I have just noticed though a yellow warning light come up on the dash which looks like a walking stick with a couple of lines / dashes running horizontal and then what looks like a drip underneath.

Is this something to do with fuel or oil pressure?
Reply
#2
I cannot picture the warning light, any chance of a pic?
Want Help with the Forum? Read Help Documents Here

Reply
#3
have you checked the oil level / does the oil pressure light go out when turning over ?
Reply
#4
Hi, I have checked the oil and it is just under the high marker and the oil appears to look normal too. The light flashes when turning over but I do not know when running as it has only been flashing since it wont start.

I am trying to get a photo of the light up now.
http://s1090.photobucket.com/albums/i372...liams2010/
Reply
#5
Hey gary

Sorry don't know the answer but think i know the symbol is this the one your talking about? If it is then someone else may be able to help you easier

[Image: bb285326.jpg]

Lliam
Lliam

53 plate Berlingo Multispace Forte 1.9D Polar White
Reply
#6
Gary do you think the heaters are getting hot
Reply
#7
Lliam, i dont think your image is working?

I can hardly ever see your images for some wierd reason, i still cant see your multi pics you recently put up after washing it.
Want Help with the Forum? Read Help Documents Here

Reply
#8
I can see the image but have know idea what it is
Reply
#9
I can see it, its like a capital F, on a yellow background.

It is indeed the oil level.

My owners manual says that it should come on for 2 - 3 secs on start up. If it flashes for ~15 s, check the oil level.
'98 D 800 van Big Grin
Reply
#10
Yes, that is the symbol. I am at a loss then as the oil is where it should be. God this week has been tough and it is starting to look like the next is going to be just as hard!
[-] The following 1 user says Thank You to garywilliams2010 for this post:
  • leeandoona
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Corrosion on a B9?
Last Post: GraemeT
Today 12:45 PM
» Replies: 10
» Views: 884
Berlingo 1.6 hdi bad knocking/tapping
Last Post: Mighty
Today 12:17 PM
» Replies: 11
» Views: 748
Cheap Berlingo Multi space
Last Post: Lighty
Today 10:46 AM
» Replies: 5
» Views: 301
1.6HDi - acceptable play on turbo shaft?
Last Post: cancunia
Today 07:23 AM
» Replies: 3
» Views: 258
Rear wiper working from indicator stalk
Last Post: TioPotz
Today 06:33 AM
» Replies: 2
» Views: 397
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Yesterday 08:20 PM
» Replies: 416
» Views: 64386
Recommend Socket Set
Last Post: evdama
Yesterday 10:40 AM
» Replies: 6
» Views: 1077
Indicator keeps blinking
Last Post: evdama
Yesterday 10:37 AM
» Replies: 1
» Views: 264
Old member returning
Last Post: ffrenchie
Yesterday 06:56 AM
» Replies: 2
» Views: 290
Wiring Diagram Berlingo M59
Last Post: Zion
Yesterday 05:25 AM
» Replies: 1
» Views: 266

[-]
Recent Visitors
Locations of visitors to this page