Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
1.4L Cruise Control
#1
Hi, 
I'm trying to get cruise running in my newly acquired Berlingo m59 1.4L KFW TU3JP.
VIN: VF7GCKFWC94366834

I've researched alot through different forums and tried many tips and tricks, but still can't seem to get it running.

Notes:
Using LEXIA 7.58, Berlingo 2 M59, Petrol, TU3JP ECU settings (ECU is a Valeo J34P)

1. Install Stalk (see picture attached)
Tested stalk in LEXIA and can see the cruise option turn on, SET +, SET - and Cancel all show up in LEXIA as working.

2. Turn on cruise in Injection ECU
I can only turn on Cruise Control with Speed Limiter. The Cruise Control without speed limiter has no option to change from Absent to Present.
Clutch Sensor set to Present
Speed Limiter set to Present

3. Turn on Cruise Control in BSI
There are 2 options. 1 - Cruise Control only 2 - Cruise Control w/ Speed Limiter
Enabling Cruise Control Only no join with testing Cruise (above 60kph in 5th)
Enabling Cruise with Speed Limiter - dash goes nuts. All lights. and lines through Odometer small tft.
This second option, I did drive it to test and the Cruise works briefly, then an error chime comes on after 5 to 10 seconds and you can't re enable. The dash won't work at all. No speedo, no Taco etc.

Have tried both options, left for 10 to 15mins. test drive, no joy.
Have tried this again and then disconnected battery after 10/15mins, still no luck.

What am I missing?
Should I be using another vehicle option in Diagbox/Lexia?
Have I got the wrong dash?
Is the speed limiter in the stalk causing issues?


   
   
   
Reply
#2
Have you got the right cruise control switch?. It looks different from mine , the wheel on mine says on or off.

I fitted a chinese made one but it just would not work with me , got an original one from a scrapper and it worked first go .
2020 Rifter 1.5 allure
2010 B9 red XTR w a v. 
2001 1.9d DW8B white  Berlingo  
2005 2.l green Berlingo
2001 1.9d DW8B white  Berlingo 
berlingo 1.4 red multispace
1993 xud 1.9 red partner
Reply
#3
(29-06-2024, 08:27 AM)brodfather11 Wrote:  Have you got the right cruise control switch?. It looks different from mine , the wheel on mine says on or off.

I fitted a chinese made one but it just would not work with me , got an original one from a scrapper and it worked first go .

Was that on a 1.4L?

The option to only enable Cruise Control (not Limiter) is not there - try and change it and it only shows 'absent'.
The only option I can enable is with the Speed Limiter.

I am seeing the buttons and cruise turn on in Lexia - can't remember where, but definitely working.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Wiring Up Towbar Electrics
Last Post: Carl.1
Today 08:10 PM
» Replies: 1
» Views: 35
berlingo 1.5 hdi problem
Last Post: vedran vk
Today 07:23 PM
» Replies: 3
» Views: 286
3rd Gen Wiper Blades Supplier
Last Post: Mark604
Today 06:13 PM
» Replies: 5
» Views: 82
New member M59 1.6 16v gasoline
Last Post: marcrbarker
Today 05:17 PM
» Replies: 10
» Views: 213
I have been accepted for a job!
Last Post: evdama
Today 03:23 PM
» Replies: 10
» Views: 188
Very brief warning light
Last Post: Fell Wanderer
Today 02:46 PM
» Replies: 3
» Views: 269
12v socket low voltage
Last Post: Drummond
Today 02:02 PM
» Replies: 2
» Views: 96
2004 sunroof wanted
Last Post: DJP49
Today 01:35 PM
» Replies: 1
» Views: 416
Air con light on
Last Post: Guanock
Today 11:09 AM
» Replies: 1
» Views: 58
odometer going from mile to kilometres while dri...
Last Post: Mark604
Today 10:57 AM
» Replies: 1
» Views: 41

[-]
Recent Visitors
Locations of visitors to this page

[-]
Hosting by

QuickHostUK