Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Air con blowing warm air
#1
Hello , I have a 2015 berlingo 1.6 HDI , I’ve recently had the air conditioning tested for leaks and regassed , fitted a new air conditioning pressure sensor , a new radiator fan relay , the air con clicks  on when pressed on and everything starts to work seems to run normal , it just doesn’t blow cold air , the radiator fan only kicks in when the engine reaches 90 degrees , I’ve had a few hours searching online and found that the radiator fan is supposed to start on low speed when the air conditioning is activated, mine doesn’t , I’ve also found that there is 2 resistors one for high speed and one for low speed , but I can’t find where they are located, any help would be much appreciated, thanks
Reply
#2
This thread may help.

https://www.berlingoforum.com/thread-216...=fan+relay
2020 Rifter 1.5 allure
2010 B9 red XTR w a v. 
2001 1.9d DW8B white  Berlingo  
2005 2.l green Berlingo
2001 1.9d DW8B white  Berlingo 
berlingo 1.4 red multispace
1993 xud 1.9 red partner
Reply
#3
Thanks for that , I’ve already changed the radiator relay , and the fan works as it should when the engine gets up to temp it kicks in , it’s just not working on low speed when I press the air con switch on , I’ve found a part number for this (6547TX) but I can’t find where they are located on my van
Reply
#4
Have you got the auto air-con with the controls like in this image?

   
_______________

Current:
Not a Citroen  Cry

Previous:
2008 B9 1.6Hdi Multispace XTR
2007 M59 1.6Hdi Multspace Desire
2002 Xsara Picasso 2.0Hdi
1996 ZX 1.9TD Estate
Reply
#5
No it’s just a single on off button with a green LED light when it’s turned on
Reply
#6
(03-07-2024, 06:15 AM)Pauluco Wrote:  No it’s just a single on off button with a green LED light when it’s turned on

Okay, are you saying that when you switch on the air con, nothing happens or are you saying when you switch on the air con and put the blower into say speed 1, 2, 3 or 4 nothing happens? 

On my Berlingo Multispace you had to switch on the aircon and select one of the blower speeds to get an output, it never switched on the blower for the air-con by just putting the air-con [green LED light switch on]

If you are saying it doesn't work on a certain speed, say speed 1, then it will be the blower resistor, located in a duct on the driver's side foot well [on a Right hand drive car] and quite awkward to get at [but is relatively easy to replace once you locate it, only held in by one screw which from memory was a small size torx head]   

If it doesn't work on any selected speeds it will be the blower relay which is located on the passenger side [on a Right had drive car] up in the lining behind the glove box, which requires you to take out some of the lining. Again relatively easy to replace once you find it, it is just a plug in type relay.
_______________

Current:
Not a Citroen  Cry

Previous:
2008 B9 1.6Hdi Multispace XTR
2007 M59 1.6Hdi Multspace Desire
2002 Xsara Picasso 2.0Hdi
1996 ZX 1.9TD Estate
Reply
#7
(03-07-2024, 10:36 AM)Multispacer Wrote:  
(03-07-2024, 06:15 AM)Pauluco Wrote:  No it’s just a single on off button with a green LED light when it’s turned on

Okay, are you saying that when you switch on the air con, nothing happens or are you saying when you switch on the air con and put the blower into say speed 1, 2, 3 or 4 nothing happens? 

On my Berlingo Multispace you had to switch on the aircon and select one of the blower speeds to get an output, it never switched on the blower for the air-con by just putting the air-con [green LED light switch on]

If you are saying it doesn't work on a certain speed, say speed 1, then it will be the blower resistor, located in a duct on the driver's side foot well [on a Right hand drive car] and quite awkward to get at [but is relatively easy to replace once you locate it, only held in by one screw which from memory was a small size torx head]   

If it doesn't work on any selected speeds it will be the blower relay which is located on the passenger side [on a Right had drive car] up in the lining behind the glove box, which requires you to take out some of the lining. Again relatively easy to replace once you find it, it is just a plug in type relay.
The air con is working as it should on all 4 speeds and when turned on the switch I here the air con clutch kick into action , but the radiator fan is not turning on low speed as it should when the air conditioning is activated , but the air con is not blowing cold cool air , I can’t  find where the resistors are located on the van , it’s supposed to have 2 resistors for the radiator fan one for high speed and one for low speed any ideas , thanks
Reply
#8
(03-07-2024, 02:27 PM)Pauluco Wrote:  
(03-07-2024, 10:36 AM)Multispacer Wrote:  
(03-07-2024, 06:15 AM)Pauluco Wrote:  No it’s just a single on off button with a green LED light when it’s turned on

Okay, are you saying that when you switch on the air con, nothing happens or are you saying when you switch on the air con and put the blower into say speed 1, 2, 3 or 4 nothing happens? 

On my Berlingo Multispace you had to switch on the aircon and select one of the blower speeds to get an output, it never switched on the blower for the air-con by just putting the air-con [green LED light switch on]

If you are saying it doesn't work on a certain speed, say speed 1, then it will be the blower resistor, located in a duct on the driver's side foot well [on a Right hand drive car] and quite awkward to get at [but is relatively easy to replace once you locate it, only held in by one screw which from memory was a small size torx head]   

If it doesn't work on any selected speeds it will be the blower relay which is located on the passenger side [on a Right had drive car] up in the lining behind the glove box, which requires you to take out some of the lining. Again relatively easy to replace once you find it, it is just a plug in type relay.
The air con is working as it should on all 4 speeds and when turned on the switch I here the air con clutch kick into action , but the radiator fan is not turning on low speed as it should when the air conditioning is activated , but the air con is not blowing cold cool air , I can’t  find where the resistors are located on the van , it’s supposed to have 2 resistors for the radiator fan one for high speed and one for low speed any ideas , thanks

The in cab blower 1-4 is working and blowing air , the air conditioning is working and clutch spinning , it’s just not providing cool/cold air , from searching online all I can find what the problem will be is the low speed radiator fan resistor for the engine cooling fan , it says on my searches that it’s supposed to start on low speed as soon as the air conditioning is activated
Reply
#9
(03-07-2024, 03:16 PM)Pauluco Wrote:  
(03-07-2024, 02:27 PM)Pauluco Wrote:  
(03-07-2024, 10:36 AM)Multispacer Wrote:  
(03-07-2024, 06:15 AM)Pauluco Wrote:  No it’s just a single on off button with a green LED light when it’s turned on

Okay, are you saying that when you switch on the air con, nothing happens or are you saying when you switch on the air con and put the blower into say speed 1, 2, 3 or 4 nothing happens? 

On my Berlingo Multispace you had to switch on the aircon and select one of the blower speeds to get an output, it never switched on the blower for the air-con by just putting the air-con [green LED light switch on]

If you are saying it doesn't work on a certain speed, say speed 1, then it will be the blower resistor, located in a duct on the driver's side foot well [on a Right hand drive car] and quite awkward to get at [but is relatively easy to replace once you locate it, only held in by one screw which from memory was a small size torx head]   

If it doesn't work on any selected speeds it will be the blower relay which is located on the passenger side [on a Right had drive car] up in the lining behind the glove box, which requires you to take out some of the lining. Again relatively easy to replace once you find it, it is just a plug in type relay.
The air con is working as it should on all 4 speeds and when turned on the switch I here the air con clutch kick into action , but the radiator fan is not turning on low speed as it should when the air conditioning is activated , but the air con is not blowing cold cool air , I can’t  find where the resistors are located on the van , it’s supposed to have 2 resistors for the radiator fan one for high speed and one for low speed any ideas , thanks

The in cab blower 1-4 is working and blowing air , the air conditioning is working and clutch spinning , it’s just not providing cool/cold air , from searching online all I can find what the problem will be is the low speed radiator fan resistor for the engine cooling fan , it says on my searches that it’s supposed to start on low speed as soon as the air conditioning is activated
Does anyone know where the 2 radiator cooling fan resistors are , Ive followed the cable from the radiator back to the fuse box and can’t find any resistors , I’ve even checked the Maxi fuses under the fuse box all in good working order , it’s just the low speed fan what is not turning , when the van is up to temp the radiator fan turns on full flow
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Part Number(s) Help Please?
Last Post: GregS
Today 08:54 PM
» Replies: 1
» Views: 36
Heavy clutch which clutch cable to buy
Last Post: MCVITIE420
Today 08:48 PM
» Replies: 0
» Views: 20
Do you need spares? My van is leaving me.
Last Post: GregS
Today 08:30 PM
» Replies: 2
» Views: 48
Replacement Cigar Lighter Socket Help.
Last Post: axxeman
Today 05:17 PM
» Replies: 10
» Views: 296
2006 M59 1.9D panel van - spares or repair.
Last Post: GregS
Today 01:50 PM
» Replies: 0
» Views: 33
Dash lights: ? & ⚠️ ……. & 011. Ok
Last Post: evdama
Today 12:39 PM
» Replies: 2
» Views: 87
New forum user 1200 rpm diesel knock
Last Post: geoff
Today 08:14 AM
» Replies: 3
» Views: 100
AC not blowing cold air
Last Post: Pauluco
Yesterday 05:47 PM
» Replies: 10
» Views: 380
Aircon compressor left the chat !
Last Post: MisterD
Yesterday 05:38 PM
» Replies: 0
» Views: 33
New member introduction
Last Post: brodfather11
Yesterday 06:14 AM
» Replies: 3
» Views: 111

[-]
Recent Visitors
Locations of visitors to this page

[-]
Hosting by

QuickHostUK