Thread Rating:
  • 16 Vote(s) - 2.06 Average
  • 1
  • 2
  • 3
  • 4
  • 5
drop links
#1
Just another problem that has occured on my 2.0hdi, recently had a coil spring and wheel bearing changed on passenger side, now im getting a small rattling noise on bumps, just changed the drop link and its still there?
Reply
#2
Top mounts?
I DO MISS MY BERLINGO Heart
[-] The following 1 user says Thank You to philip for this post:
  • Jim Ritchie
Reply
#3
Have you checked bushes on the wishbone and bottom ball joint condition?
Reply
#4
I had same experience , changed drop link still there , checked all rubbers and they fine someone told me about some lugs on strut but I never bothered to check and now I just live with the rattle
Reply
#5
Hi, with all that side being disturbed, check both bottom swivel bearing and track rod end + did you check the other drop link? It won't need much play for it to start knocking. Confusedalut:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#6
This is the thing, only had the car a year and ive changed both bottom arms, drop links, had to change a coil spring on side that is noisy so i put new mount bearing in, its only since ive had work done that its making this noise! when you say lug, do you mean the lug on the bottom of the strut?
Reply
#7
(24-06-2012, 11:55 AM)Daivanman Wrote:  This is the thing, only had the car a year and ive changed both bottom arms, drop links, had to change a coil spring on side that is noisy so i put new mount bearing in, its only since ive had work done that its making this noise! when you say lug, do you mean the lug on the bottom of the strut?

to be honest i am not too sure, its just that someone mentioned a lug on strut and that this was the problem on theres, i just dont seem to have time or even be bothered to strip it down and look and the noise is everyday life now lol
Reply
#8
Mine doing the same thing front left side, go over a bump and it makes nasty noises. One thing I do know the under tray is loose, it could be that
Reply
#9
I had a similar knock on my 1.9 slug and it turned out to be a track rod end.

Sent from my GT-I9000 using Tapatalk 2
1.9d Mk2 (M59/BE4/5) with battle scars from a conservatory attack. Previously owned a 1.4i Mk2 Forte.Confusedalut:
Reply
#10
Drop links QH tenner each and track rod ends QH 8 quid each, changed all mine a few months back after using cheap items first time round and its as silent as a mouse now.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Crankcase pressure reference values?
Last Post: saskak
Today 10:59 AM
» Replies: 0
» Views: 4
1.6hdi 2008
Last Post: cancunia
Today 08:34 AM
» Replies: 1
» Views: 188
Replacement TPS Sensor
Last Post: geoff
Today 07:16 AM
» Replies: 8
» Views: 525
Juddering when pulling away
Last Post: jj9
Yesterday 07:33 PM
» Replies: 13
» Views: 1795
Can’t find where to plug fault code reader in
Last Post: Gadgetman
Yesterday 07:22 PM
» Replies: 3
» Views: 581
Titsup
Last Post: Gadgetman
Yesterday 07:18 PM
» Replies: 14
» Views: 2254
Aux cord functionality
Last Post: Lighty
Yesterday 05:50 PM
» Replies: 3
» Views: 347
2.0 hdi abs no communication from abs ecu
Last Post: cancunia
Yesterday 02:15 PM
» Replies: 3
» Views: 246
Steering column play
Last Post: Stevjoe
Yesterday 10:05 AM
» Replies: 0
» Views: 240
Steel wheels wanted
Last Post: Art b
Yesterday 09:59 AM
» Replies: 4
» Views: 944

[-]
Recent Visitors
Locations of visitors to this page