Thread Rating:
  • 7 Vote(s) - 2.86 Average
  • 1
  • 2
  • 3
  • 4
  • 5
A/C has died
#1
Sad 
So, I have lost all bets on how long it would be before something broke! It took less than a month.

The air conditioning is not working. Pressing the dash button does absolutely nothing (no light comes on, all totally dead) I have checked the fuse which is fine and nothing obvious under the bonnet. The car came from a dealer (no warranty, just the minimum "We'll see you alright for the first 3 months guv") so I will be putting a call into them shortly. Just wondering if there are any simple checks that might be worth checking first?

Cheers
2005 Berlingo Multispace 1.6i Desire (Iron Grey)

If everything seems to be going well, you have obviously overlooked something.


Reply
#2
You checked fuses at BSI and BSM? On both devices?
Reply
#3
Excuse my ignorance, but where/what are BSI and BSM? The handbook only mentions one fuse (engine bay fuse box) and that was fine.
2005 Berlingo Multispace 1.6i Desire (Iron Grey)

If everything seems to be going well, you have obviously overlooked something.


Reply
#4
BSI - fuse box at passenger compartment.
BSM - fuse box at engine compartment.

All fuse boxes have different variants. This depends from engine and a model of Berlingo/Partner.

I suppose, that AC system is empty if compressor do not starts. There's no coolant.
Reply
#5
Have you got 12v at the back of the switch?
Dave.

08 Citroen Berlingo MkIII 1.6 hdi Vtr 90. It's gone. 'Twas a bad'un.

Yes I am an angry old fart.
Reply
#6
Update....

After changing an (apparently) unrelated fuse it is all now working perfectly again. According to the handbook the a/c fuse is in the BSM (thanks pk7478) but that particular fuse has been fine all along. While waiting to get it looked at, the fuse for the interior lights and heater blower went (which are on a separate circuit) As soon as I changed that second fuse, the a/c came back to life along with the other bits. The lights/blower had been working fine even though the a/c had stopped working earlier. Gallic quirkiness??

2005 Berlingo Multispace 1.6i Desire (Iron Grey)

If everything seems to be going well, you have obviously overlooked something.


Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
boot/trunk light not working
Last Post: densortefane
Today 02:57 PM
» Replies: 1
» Views: 114
Corrosion on a B9?
Last Post: magoo
Today 02:43 PM
» Replies: 6
» Views: 364
Stereo/CD up-grade?
Last Post: Sumo278
Today 01:28 PM
» Replies: 2
» Views: 598
Coolant leak from back of engine
Last Post: Gadgetman
Today 01:18 PM
» Replies: 10
» Views: 1332
Rear wiper working from indicator stalk
Last Post: TioPotz
Today 10:16 AM
» Replies: 0
» Views: 86
Hi everybody
Last Post: polar
Today 07:56 AM
» Replies: 1
» Views: 127
Cranks won't start no smoke
Last Post: brodfather11
Yesterday 09:05 PM
» Replies: 1
» Views: 242
I love my Berlingo
Last Post: Zweli
Yesterday 07:57 PM
» Replies: 3
» Views: 498
Oil on top of engine
Last Post: Gravity
Yesterday 05:16 PM
» Replies: 7
» Views: 533
timing belt failure
Last Post: Tree
Yesterday 02:25 PM
» Replies: 9
» Views: 1023

[-]
Recent Visitors
Locations of visitors to this page