Thread Rating:
  • 11 Vote(s) - 2.55 Average
  • 1
  • 2
  • 3
  • 4
  • 5
02 2.0Hdi Instrument console stop light
#1
Today as I slowed on the approach to traffic lights on our billiard smooth
S.E roads (NOT) the stop light cam up on the dash along with the audible bleeper no other warning lights showing :censored:. I could see or hear nothing wrong? as the traffic lights were red I stopped & restarted the engine the light & bleeper continued until the instrument's had gone throught the checks, miles to service, oil level etc then cleared. Any one any idea's, Oil level is just below the higher limit on the dip.
Reply
#2
Might have been the brake fluid level switch getting it's knickers in a twist.
Had it momentarily on mine....but I did get an error message in the display
re: Brakes. Switched off.....opened the bonnet thumped the fluid reservoir,
got back in and Presto! Stop light has not been seen when on the move since.
The fault didn't show up at the BIG service I had done on Tuesday either..
The Older I get the Better I Was!  Cool
Reply
#3
The only time i've had thuis show on mine was when the brake fluid was too low after bleeding the brakes.
Reply
#4
Mine does this too, stop light comes on but nothing else. and be at any time, doesnt seem to affect anything and all fluids are correct. in need of new pads and discs for the front would this affect it?
Reply
#5
The guy who re-programmed the ECU last week who is a Citroen electronics whizz told me that this tends to happen when the brake pads are getting worn as ( obviously) the fluid level drops. May be a sign to get them checked.Smile
The Older I get the Better I Was!  Cool
Reply
#6
The crazy thing on my Berlingo is that although it has all this so called electronic wizardry (PITA), there are no wires to the brake pads and therefore no wear indicators, similarly it does not have ABS braking.....
Berlingo Multispace 2.0HDI '54 reg Mediterranean Blue
Reply
#7
When i had my brakes overhauled the stop light kept coming on, upon further investigation by the garage it was found it was the fluid level in the second resiviour that need filling up. Once this was done all was fine.
Reply
#8
Just noticed the Brake warning light coming on randomly when braking for junctions, sometimes it beeps and light up, other times nothing... Think I'll check the fluid levels, if I need to top it up will Dot4 fluid be ok?
I ask as I have some already but it mentions on the back "not for use in Citroens"??? do they use a specific sort of brake fluid then?
Reply
#9
(23-08-2012, 10:43 AM)hachiroku Wrote:  Just noticed the Brake warning light coming on randomly when braking for junctions, sometimes it beeps and light up, other times nothing... Think I'll check the fluid levels, if I need to top it up will Dot4 fluid be ok?
I ask as I have some already but it mentions on the back "not for use in Citroens"??? do they use a specific sort of brake fluid then?

Have a look at the cap on the brake fluid reservoir, usually tells you on there of what type of fluid to use....... it is DOT4 on mine but may differ ....
Berlingo Multispace 2.0HDI '54 reg Mediterranean Blue
Reply
#10
It appears to have sorted itself out. the brake fluid level was in the OK range. The wife said earlier in the day she had a large pothole incident taking the daughter in law to a choir gig in the sticks! so bad that she'd looked to see if she had a puncture afterwards, I think it was the fluid level float getting itself in a twist and was returned to the correct level by the smaller potholes!!!! (great british roads.)
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Starter motor replacement
Last Post: alkolol
Today 12:57 PM
» Replies: 0
» Views: 7
Hello
Last Post: RostislavG
Today 12:07 PM
» Replies: 3
» Views: 453
Knocking noise over bumps
Last Post: TioPotz
Today 10:10 AM
» Replies: 7
» Views: 755
Hello from a newby
Last Post: 3rensho
Today 09:52 AM
» Replies: 1
» Views: 71
1.6 hdi lumpy cold start - SOLVED!
Last Post: cancunia
Today 08:24 AM
» Replies: 93
» Views: 14595
Heavy steering feel 2.0 HDi 2005
Last Post: cancunia
Today 08:13 AM
» Replies: 3
» Views: 398
Electrical problem... All functions blocked!
Last Post: Zion
Today 06:05 AM
» Replies: 7
» Views: 884
1.6 hdi turbo
Last Post: Zion
Today 05:48 AM
» Replies: 10
» Views: 4130
Hello and thanks for having me
Last Post: ekstrakherbal
Yesterday 10:35 PM
» Replies: 4
» Views: 532
New kid on the block
Last Post: ekstrakherbal
Yesterday 10:34 PM
» Replies: 3
» Views: 477

[-]
Recent Visitors
Locations of visitors to this page