Thread Rating:
  • 18 Vote(s) - 2.94 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Power Steering problems
#1
Hello all,
I have a 56 plate 2.0 hdi, and the power steering only works when driving.
When stopped but on tick over steering very hard.
I've had the van 18 month and only started to do this the last couple of days.
Fluid level is ok any ideas?

Cheers Jay
Reply
#2
(14-08-2012, 07:41 PM)Jr71 Wrote:  Hello all,
I have a 56 plate 2.0 hdi, and the power steering only works when driving.
When stopped but on tick over steering very hard.
I've had the van 18 month and only started to do this the last couple of days.
Fluid level is ok any ideas?

Cheers Jay

Try draining and refilling the system with a good fluid.Forte PAS fluid additive also works well.Try before condemning the system.Also check the belt is OK.
Strawberry flavoured windows  Dodgy
Reply
#3
Thanks,
I have looked at the belt seems tight enough.
Will try draining.
Cheers Jay
Reply
#4
Good luck
Strawberry flavoured windows  Dodgy
Reply
#5
I found if the belt's not tight enough it will scream at you.
Reply
#6
The belt doesn't wine or screech,
Cheers
Reply
#7
Are you sure your steering is working on the move? most vehicles lack of power steering is not noticed when once moving (old enough to remember when power steering was only fitted to Jags/ Citroen DS etc)
Reply
#8
Yes it is working when the revs go up. My first car was a vauxhall viva for £60, so I can remember cars with no power steering or brakes Smile
Reply
#9
I've drained and put fresh fluid in, but it's still the same. Can't understand why it works when you rev it up?
Reply
#10
Does seem a bit odd. Perhaps the power steering pump is on its way out. I don't suppose the belt could slip and not screech could it?
Malc

Stupid computer!
Security system should not fail safe!
Security system should fail dangerous!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Berlingo Exhaust Dilemma
Last Post: hawaiianblue
Today 05:51 PM
» Replies: 4
» Views: 116
FOR SALE: 2015, 65 plate Berlingo Van
Last Post: Tree
Today 05:47 PM
» Replies: 0
» Views: 11
Valves DW8
Last Post: Arbe
Today 05:19 PM
» Replies: 19
» Views: 1323
1.6 Hdi 'Missfire' under load (and a clonk)
Last Post: cancunia
Today 05:04 PM
» Replies: 11
» Views: 881
hi
Last Post: polar
Today 04:42 PM
» Replies: 2
» Views: 92
Major investment time.
Last Post: geoff
Today 01:45 PM
» Replies: 6
» Views: 345
DW8 cambelt whine after changing it
Last Post: Arbe
Today 12:50 PM
» Replies: 5
» Views: 789
Collected Berlingo today
Last Post: Gadgetman
Today 08:05 AM
» Replies: 6
» Views: 750
Front suspension top mounts
Last Post: hawaiianblue
Yesterday 09:04 PM
» Replies: 15
» Views: 13803
Well, I’ve bit the bullet....
Last Post: Tree
Yesterday 07:53 PM
» Replies: 2
» Views: 232

[-]
Recent Visitors
Locations of visitors to this page