Thread Rating:
  • 8 Vote(s) - 2.63 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Help fixing/replacing passenger electric window mechanism (Mk1)
#1
Question 
Hello,

I have an old Mk1 Berlingo from 1999, and the passenger electrical window mechanism is no longer working properly; it gets stuck and makes a nasty noise when opening/closing. It can be used, by repeatedly opening/closing it a bit, but I fear that it will completely break at some point soon.

I got a quote from a garage, and they quoted me almost £300 to fix it, so I would like to have a look myself to identify and fix the fault.

Does anyone know if there is a manual for removing the inside passenger door panel and window mechanism, or a guide online somewhere? I would like to avoid breaking anything if possible Wink

Many thanks!

Willi
Reply
#2
Hi Willi75,
Get the Haynes manual (should be number 4281). Tells you everything you need to know.
Regards,
Griff
Landmark
Ex 1.4 Berlingo Multispace
Reply
#3
Thanks. I read a little online about doing the same on a Mk2, and decided to try my luck. The panel came off without too much damage (1 broken clip and a couple of minor tears in the protective foam) and I was able to remove the winder mechanism.

Interestingly, it looks as though the cable, where it's wrapped around the plastic cog-like wheel adjacent to the motor, became tangled and with the force of the motor reduced the overall length of the cable and created too much stress for the little plastic clips holding the cable into the 4 white wheels at the ends of the steel rods. I managed a temp fix so the window is working again, but I can hear the cable is not running smoothly so will order a replacement.

Any suggestions for where I can buy a replacement winder mechanism? My motor works just fine, so I need the cable and all the white plastic bits Smile

Cheers,

Willi
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Overheat and antipollution?
Last Post: polar
Today 09:24 AM
» Replies: 15
» Views: 2429
02 sensor - location? Code P0030
Last Post: mikeyr
Today 09:15 AM
» Replies: 1
» Views: 152
Central locking woes!
Last Post: mikeB
Today 08:55 AM
» Replies: 16
» Views: 3386
2003 2.0 HDI Poor fuel consumption
Last Post: Norfolkboy
Today 08:37 AM
» Replies: 15
» Views: 887
adblue fuel consumption
Last Post: Tree
Today 08:13 AM
» Replies: 3
» Views: 176
Washer bottle panel rust?
Last Post: Burrotaxi
Yesterday 09:26 PM
» Replies: 0
» Views: 160
Couple pictures of my camping box
Last Post: Gadgetman
Yesterday 07:48 PM
» Replies: 2
» Views: 724
Torsion bar
Last Post: cancunia
Yesterday 07:25 PM
» Replies: 36
» Views: 3416
Risk of filter clogging
Last Post: Ikanpaul
Yesterday 06:00 PM
» Replies: 15
» Views: 3188
Berlingo vs Nissan
Last Post: Pod70
Yesterday 02:03 PM
» Replies: 3
» Views: 746

[-]
Recent Visitors
Locations of visitors to this page