Thread Rating:
  • 10 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Berlingo cutting out eng man light coming on...
#1
fuel rail pressure sensor circuit low input PO192 citroen berlingo...Has anyone had this problem and how do you fix it. I have had it serviced with new filters including fuel but it is still cutting out and engine management light coming on and showing the above code
Reply
#2
Sounds like the injector pump is giving a low pressure. A job for a garage I think, I certainly wouldn't mess around with anything to do with the fuel rail. It's super high pressure and can be dangerous.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
1.6 hdi turbo
Last Post: Fred’s adventure van
Yesterday 10:16 PM
» Replies: 13
» Views: 4351
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Yesterday 10:05 PM
» Replies: 386
» Views: 54794
Fuel Filler Replacement- 2000 Mk 1 Berlingo Mult...
Last Post: timpascoe
Yesterday 09:45 PM
» Replies: 0
» Views: 40
Starter motor replacement
Last Post: iamtoo
Yesterday 06:30 PM
» Replies: 3
» Views: 181
Sound proofing your berlingo
Last Post: robi17
Yesterday 06:23 PM
» Replies: 14
» Views: 3716
Hands free radio
Last Post: Tonyash
Yesterday 05:37 PM
» Replies: 0
» Views: 92
Hello
Last Post: RostislavG
Yesterday 12:07 PM
» Replies: 3
» Views: 578
Knocking noise over bumps
Last Post: TioPotz
Yesterday 10:10 AM
» Replies: 7
» Views: 857
Hello from a newby
Last Post: 3rensho
Yesterday 09:52 AM
» Replies: 1
» Views: 144
1.6 hdi lumpy cold start - SOLVED!
Last Post: cancunia
Yesterday 08:24 AM
» Replies: 93
» Views: 14784

[-]
Recent Visitors
Locations of visitors to this page