Thread Rating:
  • 5 Vote(s) - 3.2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Engine Loses Power (but not for long!)
#1
Hi, I'm new here. Just bought a 53 plate 1.9 hdi. It developed a fault after a week with the engine light coming on & the engine dying but only for an instant. Local garage read the fault codes & replaced the crankshaft timing sensor & the solenoid that sends unburned fuel back from the exhaust. Problem solved... for 200 miles. Now it's back except that the engine warning light doesn't come on now, I just get a moment of no power. If I dip the clutch the engine dies but if I don't it's like I bump start it & on we go.

It's booked into the garage again on Friday but I thought I'd ask if anyone's had anything similar happen.

Thanks all.
Reply
#2
(10-09-2012, 10:25 AM)Elvis1967 Wrote:  Hi, I'm new here. Just bought a 53 plate 1.9 hdi. It developed a fault after a week with the engine light coming on & the engine dying but only for an instant. Local garage read the fault codes & replaced the crankshaft timing sensor & the solenoid that sends unburned fuel back from the exhaust. Problem solved... for 200 miles. Now it's back except that the engine warning light doesn't come on now, I just get a moment of no power. If I dip the clutch the engine dies but if I don't it's like I bump start it & on we go.

It's booked into the garage again on Friday but I thought I'd ask if anyone's had anything similar happen.

Thanks all.

Hi & welcome.check the obvious first,fuel & air filter.Check tank breather is clear.Good luck.
Strawberry flavoured windows  Dodgy
Reply
#3
So this seems to be solved now. A look at the ECU and some of the wires were chafed, replaced those & it seems OK again. Somebody's obviously had the thing out & taken the lid off, I've no idea what they thought they could do in there. I only hope they just put the lid back on & backed away.

Now I've got a rumbling sound caused by a worn ball joint & wheel bearing, two front tyres that are worn on the inside and the horn's stopped working. I've had the car about 3 months & it's cost almost a grand in garage bills so far. Not the cheap runaround I was hoping for!

The tailgate wouldn't work the other day either but a squirt or two of WD40 seems to have sorted that for now...
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Torsion bar
Last Post: Satellitemark
Today 03:45 AM
» Replies: 24
» Views: 1427
Idle speed.
Last Post: benrums0n
Yesterday 10:10 PM
» Replies: 4
» Views: 607
tensioner pulley
Last Post: jj9
Yesterday 08:38 PM
» Replies: 11
» Views: 787
Berlingo vs Nissan
Last Post: Ikanpaul
Yesterday 08:29 PM
» Replies: 0
» Views: 142
Stiff clutch 2.0 hdi
Last Post: polar
Yesterday 07:35 PM
» Replies: 1
» Views: 207
multispace headliner
Last Post: Gadgetman
Yesterday 09:21 AM
» Replies: 1
» Views: 406
New Berlingo Anyone????
Last Post: msw109
20-01-2019 09:54 PM
» Replies: 5
» Views: 867
Berlingo----- Console
Last Post: Satellitemark
20-01-2019 08:53 PM
» Replies: 5
» Views: 984
Partner 3 seat (front) conversion
Last Post: dumdum
20-01-2019 08:33 PM
» Replies: 0
» Views: 178
How did the Berlingo get it's name ?
Last Post: Egg on Leggs
20-01-2019 07:07 PM
» Replies: 15
» Views: 3155

[-]
Recent Visitors
Locations of visitors to this page