Thread Rating:
  • 8 Vote(s) - 4.13 Average
  • 1
  • 2
  • 3
  • 4
  • 5
1998 1.8 Petrol - Loss of Engine Power
#1
Sad 
Yesterday the engine developed a fault that appeared to be just a slight misfire but soon after became a complete loss of power. AA called and could not fix the problem but Relayed vehicle to my local garage. AA chap suggested it may be a cracked inlet manifold cover or a faulty electronic sensor. When the sensor was disconnected the engine would operate and rev normally.

Prior to this catastrophic problem, the car would sometimes stall when the engine was idling. Removing an electrical load such as the Air Con and/or fan would stop this happening.

I spoke to my local garage earlier today and the mechanic had been able to road test the vehicle - no fault found!!!!!! Incredibly frustrating. He was unable to connect to the fault access computer.

Do these symptoms point to anything specific? Could the gradual but complete loss of engine power and the stalling at idle be a related electrical problem, if so what is the likely cause?

Thanks.

Hofmeister
Reply
#2
If this is an intermittent fault I would be checking all of the electrical earths scattered around the
vehicle. Certainly the main engine and gearbox earths.
You don't say which sensor (there are a few) if disconnected allows the engine to run.
The Older I get the Better I Was!  Cool
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Replacement TPS Sensor
Last Post: jimbo
Yesterday 10:34 PM
» Replies: 10
» Views: 711
Crankcase pressure reference values?
Last Post: saskak
Yesterday 09:46 PM
» Replies: 2
» Views: 177
Powerflex Front Anti Roll Bar Bushes
Last Post: NANO_Vigo
Yesterday 08:52 PM
» Replies: 0
» Views: 48
Juddering when pulling away
Last Post: magoo
Yesterday 08:30 PM
» Replies: 16
» Views: 2113
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Yesterday 07:47 PM
» Replies: 707
» Views: 161263
new member needing lots of help
Last Post: cancunia
Yesterday 05:44 PM
» Replies: 12
» Views: 1424
2.0 hdi abs no communication from abs ecu
Last Post: cancunia
Yesterday 04:48 PM
» Replies: 5
» Views: 407
B9 Head Unit Upgrade
Last Post: dumdum
Yesterday 03:56 PM
» Replies: 2
» Views: 372
Longshot... dash pics required
Last Post: dumdum
Yesterday 03:47 PM
» Replies: 0
» Views: 111
Titsup
Last Post: Martinez
Yesterday 12:55 PM
» Replies: 16
» Views: 2755

[-]
Recent Visitors
Locations of visitors to this page