Thread Rating:
  • 7 Vote(s) - 2.57 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problematic heater fan...
#1
Hi,

After having to get the gearbox replaced on the 2.0hDi I bought a week ago, I got to drive it for the first time this weekend :woop:

One thing I have noticed is that the heater fan will only operate on No.4 (full blast) and it is particularly loud. No.'s 1-3 don't do anything...:S

I can still operate the heat settings as you can feel it when driving at speed.

Anybody got any ideas?? Confusedcratch:
Reply
#2
Have a look around the forum matey, quite a bit written on this subject
Berlingo Multispace 2.0HDI '54 reg Mediterranean Blue
[-] The following 1 user says Thank You to andy-womble for this post:
  • Merlecollins
Reply
#3
I had the same thing on my old renault kangoo it was the resistor bank attached to the blower. They are protected by a couple of thermal fuses and the one for the lower speeds has failed. I unclipped mine and soldered a new fuse in brought from maplin for 10p I think but you probably can get a new part. Im just a skin flint by nature.
Are we there yet????? Huh
Ex 1.6hdi van now 3 seater 1.4 multispace
[-] The following 1 user says Thank You to Tomcat3 for this post:
  • Merlecollins
Reply
#4
Yeah it is the resistor pack that is faulty.

The resistors are 6 or 7 quid each but you have to tinker and solder them in. You can buy a new resistor pack off ebay for about £15 to £20.

I just replaced mine for a second time the other week.
[-] The following 1 user says Thank You to tucker for this post:
  • Merlecollins
Reply
#5
Hi and thanks very much, that sounds a pretty unanimous verdict Smile

Is the blower behind the glovebox and when I drop it out is it pretty self evident which part I need to take off? Can't seem to see one for hDi models on Ebay, so might have to go to the dealer.



(24-09-2012, 09:51 PM)tucker Wrote:  Yeah it is the resistor pack that is faulty.

The resistors are 6 or 7 quid each but you have to tinker and solder them in. You can buy a new resistor pack off ebay for about £15 to £20.

I just replaced mine for a second time the other week.
Reply
#6
It's below the glovebox.

Unclip the carpet trim that goes from the bottom of the dash to the top of the footwell and you will see it.
[-] The following 1 user says Thank You to Coco for this post:
  • Merlecollins
Reply
#7
Have a look at this as it shows you the process of removal etc... If you buy the whole part, you won't need to follow all of this as the instructions are for replacing the small resistors:

resistor replacement

The resistor pack is the same part for the HDI. You just need something like this:

seller
[-] The following 2 users say Thank You to tucker for this post:
  • Merlecollins, Rustscrat
Reply
#8
Thats incredibly helpful Coco and Tucker - many thanks especially for the 2 links Tucker they will be invaluable Big Grin

I'm going to order the complete Ebay part and have a crack at it once that arrives.

Thanks again :thumbsup:

(25-09-2012, 08:57 AM)tucker Wrote:  Have a look at this as it shows you the process of removal etc... If you buy the whole part, you won't need to follow all of this as the instructions are for replacing the small resistors:

resistor replacement

The resistor pack is the same part for the HDI. You just need something like this:

seller
Reply
#9
My Wife's Micra used to suffer with this problem. You could solder a piece of wire across the fusible links but.... it used to get hot enough to desolder or blow another part of the resistor. After having repaired it a couple of times I took the fan out and found it was quite stiff to move. The other symptom was that it wouldn't work unless you put it on full power then switched it down to the appropriate speed. I blew out the carbon dust from the brushes, cleaned the commutator and oiled the bearings. Works like a new one now!
Malc

Stupid computer!
Security system should not fail safe!
Security system should fail dangerous!
[-] The following 1 user says Thank You to crickleymal for this post:
  • Merlecollins
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Can i get away with 205/70r15
Last Post: geoff
Yesterday 11:38 PM
» Replies: 8
» Views: 1144
How I installed an oil catch can in the 1.6HDi
Last Post: saskak
Yesterday 09:59 PM
» Replies: 3
» Views: 523
Eco-mode behaviour . . . .
Last Post: Lighty
Yesterday 09:46 PM
» Replies: 7
» Views: 453
Juddering when pulling away
Last Post: dumdum
Yesterday 09:33 PM
» Replies: 5
» Views: 688
Hello new member and warning light issues.
Last Post: Jamespworth
Yesterday 08:44 PM
» Replies: 3
» Views: 364
Witter PG46C Towbar 2008 on
Last Post: Jakejjt
Yesterday 08:28 PM
» Replies: 0
» Views: 82
Steel wheels wanted
Last Post: Jakejjt
Yesterday 08:10 PM
» Replies: 3
» Views: 551
Driver door lock problem help!!
Last Post: SantubearSex
Yesterday 07:36 PM
» Replies: 1
» Views: 128
Reimo Vertic cabin tailgate tent
Last Post: BerlingoAndy
Yesterday 07:14 PM
» Replies: 10
» Views: 858
Pioneer double din
Last Post: dumdum
Yesterday 07:11 PM
» Replies: 0
» Views: 99

[-]
Recent Visitors
Locations of visitors to this page