Thread Rating:
  • 23 Vote(s) - 3.61 Average
  • 1
  • 2
  • 3
  • 4
  • 5
stereo fitting probs
#1
Hiya folks, I got around to fitting a CD player instead of the cassette that was originally fitted. It came from a late Peugeot with the same pin configuration as the Citroen one and I had the radio code, so I was hoping for a reasonably carefree exchange...and although the stereo works fine, the central console display seems to have taken a disklike to its' new companion and now tells me the (correct) time when I turn on but doesn't change again until the next time I turn on when it will again show me the correct time. Also the stalk controls have stopped working. Is there any previous experience of something like this happening? Thanks in advance for any info..Dave
2005 Multispace 1.9D poseidon blue
Reply
#2
hi Dave. did you disconnect the battery before installing radio unit? Sometimes it can help to disconnect for 10 minutes or so to reset BSI. ( nasty computer) Do you have the date displayed and RDS, stereo etc on the centre console display bottom line? As for the steering controls try the above battery disconnect to see whether it works, however peugeot part may not be compatible in the first instance, let me know how it goes.
Adam..2003..1.9D..LX..Silver Crew Cab Van.....
If at first you don't succeed, destroy all evidence that you tried.
Reply
#3
I had a few problems with my clock but I have an aftermarket stereo when disconnecting my battery for my sub it sorted the clock out but as I say mine is an aftermarket stereo

Lliam
Lliam

53 plate Berlingo Multispace Forte 1.9D Polar White
Reply
#4
Try whats been said above, ive heard it may be the problem some times!
Want Help with the Forum? Read Help Documents Here

Reply
#5
if disconnecting the battery fails to work, you may need to get the BSI reprogrammed to recognize that the original head unit is no longer there ....
53 plate 1.9d Multispace Forte

Upgraded t'wireless and front speakers, loads more planned but not much action.. Wink
Reply
#6
I have just fitted an aftermarket (Kenwood) CD/MP3 head unit, with stalk compatibility (extra harness required!)....fitted in no time, works an absolute treat on the stalk But....You do lose the top dash display, it now just reads the date and time permanently...No big deal as the stalk brings up all the info' you require on the head unit display.

Highly recommended, especially as you can plug your IPod/MP3 player into the 3.5mm jack plug!....£79.99 of fleabay.
MPV (My own Personal Vehicle)....2.0 HDi Multispace MPV Mk2 .

I Like Cars,Women,Drink & Motorbikes but not necessarily in that order!
Reply
#7
Hi everyone and thanks for your replies. I didn't disconnect the battery at the time, so that is definitely my first step. Cheers and it's good to see the membership numbers going up so well. Dave
2005 Multispace 1.9D poseidon blue
Reply
#8
I was going to say grimsqueaker would suggest going to dealer but he already posted it lol

Lliam
Lliam

53 plate Berlingo Multispace Forte 1.9D Polar White
[-] The following 1 user says Thank You to lemsworld for this post:
  • Grimsqueaker
Reply
#9
Hi fellas, disconnected battery and left it a while before reconnecting and the console display is working again.
Not a problem for me but the stalk controls still inactive...most probably because radio is not fully compatible. Regards..Dave
2005 Multispace 1.9D poseidon blue
[-] The following 1 user says Thank You to dave tregidon for this post:
  • adam3rdcanvey
Reply
#10
Dave.

Nice to see the display has recovered.
You could probably get an interface for your unit to retain operation of the controls from a company online called Autoleads It will cost a good few quid though!!!

I will try and do some digging around tomorrow to check the wiring diagrams for Citroen/ Peugeot compatability. Could just be the cassette-CD changover has rendered the previous steering controls defunct?
Adam..2003..1.9D..LX..Silver Crew Cab Van.....
If at first you don't succeed, destroy all evidence that you tried.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Today 10:49 PM
» Replies: 687
» Views: 151066
One brake light working
Last Post: dumdum
Today 11:36 AM
» Replies: 11
» Views: 904
Rear Hub Nut Size
Last Post: ntm1275
Yesterday 11:06 PM
» Replies: 4
» Views: 908
Engine noise
Last Post: cancunia
Yesterday 05:01 PM
» Replies: 31
» Views: 14416
Cruise control (again), yes again, but working (...
Last Post: cancunia
23-03-2019 01:24 PM
» Replies: 101
» Views: 15707
2003 2.0 HDI Poor fuel consumption
Last Post: Trevor
23-03-2019 12:38 PM
» Replies: 34
» Views: 10357
puff of blue-ish smoke on startup
Last Post: Art b
22-03-2019 10:37 PM
» Replies: 12
» Views: 1506
Speedo / Instrument Cluster Removal
Last Post: cancunia
22-03-2019 04:05 PM
» Replies: 2
» Views: 400
airbag stolen - is it a thing
Last Post: rapidyellow
22-03-2019 10:39 AM
» Replies: 3
» Views: 837
EGR valve
Last Post: cancunia
22-03-2019 10:19 AM
» Replies: 1
» Views: 224

[-]
Recent Visitors
Locations of visitors to this page