Thread Rating:
  • 7 Vote(s) - 2.86 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] pre-heater coil
#1
hello, i have a 2004 2.0 hdi multi-space, forte berlingo, what i want to know is that the pre-heater coil light only comes on when its severely cold, i think i have only seen it come on a handful of times in the 18 months i have had the car, the car has never let me down but it doesnt fire straight away , i have had a few diesel cars normally they would fire pretty instantly, it takes a few turns from cold to fire when warm no problem, i just thought someone could tell me why that light doesnt come on, thinking it needs that help to fire, any info or pointers appreciated sorry if i have rambled, cheers.
Reply
#2
Plenty of info elsewhere on site if you wish to have a trawl around...
Berlingo Multispace 2.0HDI '54 reg Mediterranean Blue
Reply
#3
(28-10-2012, 12:38 PM)andy-womble Wrote:  Plenty of info elsewhere on site if you wish to have a trawl around...

cheers andy have read a few posts seems its common that the light doesnt come on unless its very cold, i think that it might be indicating a new battery i will see how it goes, thanks again.
Reply
#4
The glow plug light comes on only when the outside temperature
drops to below freezing and is then on only for a few seconds.
The Older I get the Better I Was!  Cool
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Starter motor replacement
Last Post: alkolol
Today 12:57 PM
» Replies: 0
» Views: 15
Hello
Last Post: RostislavG
Today 12:07 PM
» Replies: 3
» Views: 458
Knocking noise over bumps
Last Post: TioPotz
Today 10:10 AM
» Replies: 7
» Views: 760
Hello from a newby
Last Post: 3rensho
Today 09:52 AM
» Replies: 1
» Views: 75
1.6 hdi lumpy cold start - SOLVED!
Last Post: cancunia
Today 08:24 AM
» Replies: 93
» Views: 14607
Heavy steering feel 2.0 HDi 2005
Last Post: cancunia
Today 08:13 AM
» Replies: 3
» Views: 402
Electrical problem... All functions blocked!
Last Post: Zion
Today 06:05 AM
» Replies: 7
» Views: 888
1.6 hdi turbo
Last Post: Zion
Today 05:48 AM
» Replies: 10
» Views: 4134
Hello and thanks for having me
Last Post: ekstrakherbal
Yesterday 10:35 PM
» Replies: 4
» Views: 533
New kid on the block
Last Post: ekstrakherbal
Yesterday 10:34 PM
» Replies: 3
» Views: 477

[-]
Recent Visitors
Locations of visitors to this page