Thread Rating:
  • 5 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Starting issue
#1
Hi, got a 1.9 Citreon Diesel van ( 600 ). When I turn on the ignition on the orange glow plug light on the dashboard instantly goes off instead of staying on for the usual ten seconds or so. This is making it almost impossible to start the van, the van will run as normal with carb start but not on it's own from the key as the glow plugs are obviously not getting warm.

any ideas what part is broken and stopping the glow plugs heating up?
Reply
#2
see this post

http://www.berlingoforum.co.uk/showthread.php?tid=1875

:thumbsup:

or this one
http://www.berlingoforum.co.uk/showthread.php?tid=3891
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Berlingo Exhaust Dilemma
Last Post: geoff
Today 04:59 PM
» Replies: 6
» Views: 412
Valves DW8
Last Post: geoff
Today 02:30 PM
» Replies: 22
» Views: 1865
Major investment time.
Last Post: geoff
Today 12:28 PM
» Replies: 9
» Views: 633
FOR SALE: 2015, 65 plate Berlingo Van
Last Post: Tree
Today 09:45 AM
» Replies: 1
» Views: 263
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Today 08:47 AM
» Replies: 526
» Views: 92277
Lesure battery charging
Last Post: jtr rhyl
Today 08:41 AM
» Replies: 2
» Views: 147
Speaker mounting depth
Last Post: SayAnything
Today 07:51 AM
» Replies: 4
» Views: 264
Front and rear washers
Last Post: hawaiianblue
Yesterday 11:32 PM
» Replies: 1
» Views: 239
1.6 Hdi 'Missfire' under load (and a clonk)
Last Post: GraemeT
Yesterday 09:06 PM
» Replies: 12
» Views: 1378
hi
Last Post: polar
Yesterday 04:42 PM
» Replies: 2
» Views: 272

[-]
Recent Visitors
Locations of visitors to this page