Thread Rating:
  • 4 Vote(s) - 2.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
air flow need help asap
#1
Hey I have a prob wa my 1.6 hdi 75bhp van it is remapd for a bit nw but da light came on on da dash and took it to get pluged in and it came up mass air folw so I got 1 2nd hand and cleard da fults but still came up on da com but da light wint out but when I was driveing I came bk on so now I have pit 3 in it and still da same wa can it be like can any1 help
Reply
#2
Were either of the other MAF sensors you tried, new? If not, I'd be looking hard at a new genuine unit. Did the remap delete FAP and cat?

Also, are you certain it's the MAF at fault? Some non-genuine code scanners seem to pick faults out of thin air.
[-] The following 1 user says Thank You to addo for this post:
  • mckay
Reply
#3
Maf sensor fault often appears and is incorrect, is it low flow at airflow?
Could be blocked air filter, split hose etc etc.
U need Lexia, and someone who knows how to use it my friend .
[-] The following 1 user says Thank You to Lighty for this post:
  • mckay
Reply
#4
(19-12-2012, 07:10 AM)Lighty Wrote:  U need Lexia, and someone who knows how to use it my friend .

I reckon he needs a new speak and spell as well :whistle:
Somedays you're the pigeon, Somedays you're the statue.
[-] The following 1 user says Thank You to steve valentine for this post:
  • andy-womble
Reply
#5
He may get more offers of help if people can understand him, I must need a translator or a " text " dictionary.
[-] The following 2 users say Thank You to geoff for this post:
  • andy-womble, ron
Reply
#6
(19-12-2012, 03:28 AM)addo Wrote:  Were either of the other MAF sensors you tried, new? If not, I'd be looking hard at a new genuine unit. Did the remap delete FAP and cat?

Also, are you certain it's the MAF at fault? Some non-genuine code scanners seem to pick faults out of thin air.

im not to sure wa da remap del like i no dat i took da cat out i had it on da lexia and sed maf egr and fuel temp so i cleared dem and da light came bk on down da rode ffs heads going to go

(19-12-2012, 07:10 AM)Lighty Wrote:  Maf sensor fault often appears and is incorrect, is it low flow at airflow?
Could be blocked air filter, split hose etc etc.
U need Lexia, and someone who knows how to use it my friend .

i no its na da air filtter i have got a new 1 in it like thinks

(19-12-2012, 08:29 AM)steve valentine Wrote:  I reckon he needs a new speak and spell as well :whistle:
i just cant spell like sorry
Reply
#7
Hi There,
Easiest solution first ;
Open up the maf sensor and squirt non-residual clening spray,available from maplins at 1.75 a can.Target the needle like protrusion inside the sensor but do not touch it.Refit it .See if this cures the problem if not a new maf sensor needed.never buy second hand anything electronic..not worth the hassle.
good luck and let us know how you got on.
Reply
#8
I bought a new MAF from here

http://www.euroautomotive.co.uk/peugeot-...9621-p-120
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
new mot
Last Post: saskak
Today 03:37 PM
» Replies: 13
» Views: 1865
Heater control panel
Last Post: Gravity
Today 03:37 PM
» Replies: 1
» Views: 41
Amdro Boot Jump
Last Post: Gravity
Today 02:19 PM
» Replies: 1
» Views: 41
Front door quarter window replacement
Last Post: dumdum
Today 02:03 PM
» Replies: 0
» Views: 39
B9 Camper Build with Step by Step Photos
Last Post: Gravity
Today 09:34 AM
» Replies: 39
» Views: 6701
Horn wiring
Last Post: webcrafty
Today 07:47 AM
» Replies: 2
» Views: 212
Disc pads.
Last Post: ffrenchie
Today 07:15 AM
» Replies: 9
» Views: 602
newbie
Last Post: geoff
Yesterday 09:52 PM
» Replies: 2
» Views: 263
Dw8 fuel pump seal help
Last Post: colinh
Yesterday 07:36 AM
» Replies: 4
» Views: 600
Forum newb slightly cheating...
Last Post: Gadgetman
22-05-2018 10:09 PM
» Replies: 3
» Views: 426

[-]
Recent Visitors
Locations of visitors to this page