Thread Rating:
  • 6 Vote(s) - 2.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
serviced and still poor mpg
#1
Hi everyone,

First van i have owned and has the worst mpg so far. its a 1.9d 1999 van with 144k. Ive just done a small service on it cam belt, aux belt, fuel filter, air filter, oil and filter. petrol light came on so put bp ultimate in £30 at 1.46 ltr. (not cheap i know) just to run it with some good fuel to maybe help clean the fuel ways im currently at 90 miles and not far off the light coming on may hit around 110-120 at best and had nothing in the back either! wheel pressures was done before this too. also seems you need to really put your foot down for this van to move, are they all like this?

what can it be as im sure it can do better.


its a mixture of motorway and town.
Reply
#2
Sounds like you have covered the basics, maybe valve clearances are wrong, although this usually causes poor starting.
Check the cold start device on the pump, it is a cable device operated by a wax stat next too the top hose. When they fail, they stick full on, raising the idle speed and fuel mixture.
I have just disconnected mine, on my C 15. Still starts and runs fine.
[-] The following 1 user says Thank You to Lighty for this post:
  • amtech
Reply
#3
There was a thread on here recently about the cold start device and how to replace it and these 1.9 vans are a bit of a plodder but reliable. Are the brakes sticking slightly, only way to do an accurate check on fuel is full tank to full tank as the
gauges have a big margin.
Are we there yet????? Huh
Ex 1.6hdi van now 3 seater 1.4 multispace
[-] The following 2 users say Thank You to Tomcat3 for this post:
  • amtech, ron
Reply
#4
thank you all for the replies, i have noticed on my slightly slopped drive my zafira rolls on its own once the handbrake has been released as where the berlingo needs a bit of help. may look at the drums/handbrake shoes . Also is the a pic of this device? cannot find this thread.
Reply
#5
Have a look at this thread http://www.berlingoforum.co.uk/showthrea...cold+start
I think its in here.
Are we there yet????? Huh
Ex 1.6hdi van now 3 seater 1.4 multispace
[-] The following 1 user says Thank You to Tomcat3 for this post:
  • amtech
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Coil pack for 1.4 petrol
Last Post: mikeyr
Yesterday 11:49 PM
» Replies: 0
» Views: 26
THE ITALIAN BOX ?
Last Post: THE BADGE
Yesterday 09:29 PM
» Replies: 5
» Views: 397
My new partner (well it’s the same van!)
Last Post: Trevor
Yesterday 09:17 PM
» Replies: 3
» Views: 123
new vehicle
Last Post: Javier_432
Yesterday 08:56 PM
» Replies: 8
» Views: 2809
How Often Does AC Need Re-Gassing?
Last Post: hawaiianblue
Yesterday 06:44 PM
» Replies: 16
» Views: 1231
Peugeot partner 09 1.6hdi 75bhp
Last Post: dumdum
Yesterday 05:58 PM
» Replies: 0
» Views: 111
Hi from the Midlands UK
Last Post: dumdum
Yesterday 04:57 PM
» Replies: 3
» Views: 495
Lowering fun
Last Post: dumdum
Yesterday 04:54 PM
» Replies: 10
» Views: 1212
Full 1.9D Van Spares
Last Post: TONX
Yesterday 04:33 PM
» Replies: 0
» Views: 123
Major investment time.
Last Post: malgpz900
Yesterday 12:04 PM
» Replies: 24
» Views: 3632

[-]
Recent Visitors
Locations of visitors to this page