Thread Rating:
  • 6 Vote(s) - 2.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
serviced and still poor mpg
#1
Hi everyone,

First van i have owned and has the worst mpg so far. its a 1.9d 1999 van with 144k. Ive just done a small service on it cam belt, aux belt, fuel filter, air filter, oil and filter. petrol light came on so put bp ultimate in £30 at 1.46 ltr. (not cheap i know) just to run it with some good fuel to maybe help clean the fuel ways im currently at 90 miles and not far off the light coming on may hit around 110-120 at best and had nothing in the back either! wheel pressures was done before this too. also seems you need to really put your foot down for this van to move, are they all like this?

what can it be as im sure it can do better.


its a mixture of motorway and town.
Reply
#2
Sounds like you have covered the basics, maybe valve clearances are wrong, although this usually causes poor starting.
Check the cold start device on the pump, it is a cable device operated by a wax stat next too the top hose. When they fail, they stick full on, raising the idle speed and fuel mixture.
I have just disconnected mine, on my C 15. Still starts and runs fine.
[-] The following 1 user says Thank You to Lighty for this post:
  • amtech
Reply
#3
There was a thread on here recently about the cold start device and how to replace it and these 1.9 vans are a bit of a plodder but reliable. Are the brakes sticking slightly, only way to do an accurate check on fuel is full tank to full tank as the
gauges have a big margin.
Are we there yet????? Huh
Ex 1.6hdi van now 3 seater 1.4 multispace
[-] The following 2 users say Thank You to Tomcat3 for this post:
  • amtech, ron
Reply
#4
thank you all for the replies, i have noticed on my slightly slopped drive my zafira rolls on its own once the handbrake has been released as where the berlingo needs a bit of help. may look at the drums/handbrake shoes . Also is the a pic of this device? cannot find this thread.
Reply
#5
Have a look at this thread http://www.berlingoforum.co.uk/showthrea...cold+start
I think its in here.
Are we there yet????? Huh
Ex 1.6hdi van now 3 seater 1.4 multispace
[-] The following 1 user says Thank You to Tomcat3 for this post:
  • amtech
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Cruise control (again), yes again, but working (...
Last Post: Collapsedsuspension
Today 10:09 AM
» Replies: 96
» Views: 7377
Dingo - 05 - 2.0 HDI
Last Post: coakers
Today 04:16 AM
» Replies: 61
» Views: 11032
Heater problems
Last Post: Fuseman
Yesterday 08:34 PM
» Replies: 2
» Views: 249
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Yesterday 08:21 PM
» Replies: 312
» Views: 34288
side loading handle
Last Post: Hung2hi
19-05-2018 02:57 PM
» Replies: 9
» Views: 1089
exhaust
Last Post: Hung2hi
19-05-2018 02:45 PM
» Replies: 10
» Views: 936
Fuel Expansion Tank
Last Post: Collapsedsuspension
19-05-2018 08:17 AM
» Replies: 4
» Views: 510
DAB reception since TV retune on thursday
Last Post: kenny70
19-05-2018 07:11 AM
» Replies: 8
» Views: 1023
B9 Camper Build with Step by Step Photos
Last Post: Hardnut
19-05-2018 03:45 AM
» Replies: 36
» Views: 5883
Rear door
Last Post: Jakejjt
18-05-2018 11:17 PM
» Replies: 2
» Views: 438

[-]
Recent Visitors
Locations of visitors to this page