Thread Rating:
  • 9 Vote(s) - 2.33 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Old Berlingo, new member, mystic problem
#1
hi,

i m knew here, so maybe i start by introducing my entry. I ve just bought a 2001 Berlingo for my wife for 900 euro. It's a 1.4l with 75 horse power and it has 130000 kilometer on the clock. We' re from Belgium, so that may explain the languages faults.
As you can imagine, there is some work to be done on the car.

my father is the one who has the handy hands. he just changed some rubbers at the front wheels. New brakes were put in the front.

But for now, we have one big problem. I've searched the forum, but didn't find a similar problem. The car hardly makes it to 120 kilometer an hour. It starts fine, runs fine, it can get out of underground garage, so there is power. But it doesn't run fast. So if anyone has a suggestion where the problem may lie... we would be thankfull.

And then an another informative thing. Has anyone ever seen a Berlingo in rat look?

thnx

greetings from belgium
Reply
#2
Hi, the common internal reasons for your van not running well, are in order of significance:

Bad spark (worn spark plugs or dying ignition coil)
Fuel problems (defective pump, pressure regulator, or blocked fuel filter)
Blocked catalytic converter
Camshaft timing set wrong. This can be tested by "pinning" the crank and camshaft (Link)
[-] The following 1 user says Thank You to addo for this post:
  • Belgianberlingo
Reply
#3
Thnx! We'll try these.
Reply
#4
(26-02-2013, 10:54 PM)Belgianberlingo Wrote:  hi,

i m knew here, so maybe i start by introducing my entry. I ve just bought a 2001 Berlingo for my wife for 900 euro. It's a 1.4l with 75 horse power and it has 130000 kilometer on the clock. We' re from Belgium, so that may explain the languages faults.
As you can imagine, there is some work to be done on the car.

my father is the one who has the handy hands. he just changed some rubbers at the front wheels. New brakes were put in the front.

But for now, we have one big problem. I've searched the forum, but didn't find a similar problem. The car hardly makes it to 120 kilometer an hour. It starts fine, runs fine, it can get out of underground garage, so there is power. But it doesn't run fast. So if anyone has a suggestion where the problem may lie... we would be thankfull.

And then an another informative thing. Has anyone ever seen a Berlingo in rat look?

thnx

greetings from belgium

Hi BB, I started to rat my old battered mrk1 berlingo a few months ago .


look out for pics of DARTH on http://www.rat-look.com in the near future.
[-] The following 1 user says Thank You to nocomedians for this post:
  • RolyG
Reply
#5
Rat Berlingo that would be cool but i dought Mrs would be inprssed.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Amdro Boot Jump for sale, £1400
Last Post: berlingagogo
Yesterday 10:29 PM
» Replies: 2
» Views: 349
Engine Fault Light Error Code P1434
Last Post: kingy1912
Yesterday 10:18 PM
» Replies: 2
» Views: 341
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Yesterday 09:50 PM
» Replies: 352
» Views: 44395
More power
Last Post: BerlingoFox
Yesterday 09:15 PM
» Replies: 0
» Views: 88
1.6 hdi lumpy cold start
Last Post: Zion
Yesterday 09:04 PM
» Replies: 50
» Views: 6092
Dingo - 05 - 2.0 HDI
Last Post: coakers
Yesterday 08:34 PM
» Replies: 79
» Views: 16179
ENGINE WONT START WHEN HOT
Last Post: DMD
Yesterday 03:02 PM
» Replies: 6
» Views: 602
Bonnet Bump Stops
Last Post: Matt Haigh
Yesterday 01:03 PM
» Replies: 2
» Views: 336
Amdro Boot Jump for sale, £1400
Last Post: berlingagogo
20-06-2018 09:57 PM
» Replies: 0
» Views: 295
Panoramic sunroof (+2008) model for weekend camp...
Last Post: BerlingoAndy
20-06-2018 08:45 PM
» Replies: 2
» Views: 340

[-]
Recent Visitors
Locations of visitors to this page