Thread Rating:
  • 9 Vote(s) - 2.33 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Old Berlingo, new member, mystic problem
#1
hi,

i m knew here, so maybe i start by introducing my entry. I ve just bought a 2001 Berlingo for my wife for 900 euro. It's a 1.4l with 75 horse power and it has 130000 kilometer on the clock. We' re from Belgium, so that may explain the languages faults.
As you can imagine, there is some work to be done on the car.

my father is the one who has the handy hands. he just changed some rubbers at the front wheels. New brakes were put in the front.

But for now, we have one big problem. I've searched the forum, but didn't find a similar problem. The car hardly makes it to 120 kilometer an hour. It starts fine, runs fine, it can get out of underground garage, so there is power. But it doesn't run fast. So if anyone has a suggestion where the problem may lie... we would be thankfull.

And then an another informative thing. Has anyone ever seen a Berlingo in rat look?

thnx

greetings from belgium
Reply
#2
Hi, the common internal reasons for your van not running well, are in order of significance:

Bad spark (worn spark plugs or dying ignition coil)
Fuel problems (defective pump, pressure regulator, or blocked fuel filter)
Blocked catalytic converter
Camshaft timing set wrong. This can be tested by "pinning" the crank and camshaft (Link)
[-] The following 1 user says Thank You to addo for this post:
  • Belgianberlingo
Reply
#3
Thnx! We'll try these.
Reply
#4
(26-02-2013, 10:54 PM)Belgianberlingo Wrote:  hi,

i m knew here, so maybe i start by introducing my entry. I ve just bought a 2001 Berlingo for my wife for 900 euro. It's a 1.4l with 75 horse power and it has 130000 kilometer on the clock. We' re from Belgium, so that may explain the languages faults.
As you can imagine, there is some work to be done on the car.

my father is the one who has the handy hands. he just changed some rubbers at the front wheels. New brakes were put in the front.

But for now, we have one big problem. I've searched the forum, but didn't find a similar problem. The car hardly makes it to 120 kilometer an hour. It starts fine, runs fine, it can get out of underground garage, so there is power. But it doesn't run fast. So if anyone has a suggestion where the problem may lie... we would be thankfull.

And then an another informative thing. Has anyone ever seen a Berlingo in rat look?

thnx

greetings from belgium

Hi BB, I started to rat my old battered mrk1 berlingo a few months ago .


look out for pics of DARTH on http://www.rat-look.com in the near future.
[-] The following 1 user says Thank You to nocomedians for this post:
  • RolyG
Reply
#5
Rat Berlingo that would be cool but i dought Mrs would be inprssed.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Recommend Socket Set
Last Post: evdama
Today 10:40 AM
» Replies: 6
» Views: 797
Indicator keeps blinking
Last Post: evdama
Today 10:37 AM
» Replies: 1
» Views: 155
Berlingo 1.6 hdi bad knocking/tapping
Last Post: polar
Today 10:28 AM
» Replies: 6
» Views: 219
Old member returning
Last Post: ffrenchie
Today 06:56 AM
» Replies: 2
» Views: 184
Wiring Diagram Berlingo M59
Last Post: Zion
Today 05:25 AM
» Replies: 1
» Views: 177
Cranks won't start no smoke
Last Post: Zweli
Yesterday 07:02 PM
» Replies: 2
» Views: 419
Corrosion on a B9?
Last Post: V6BOY
Yesterday 04:22 PM
» Replies: 7
» Views: 550
boot/trunk light not working
Last Post: densortefane
Yesterday 02:57 PM
» Replies: 1
» Views: 247
Stereo/CD up-grade?
Last Post: Sumo278
Yesterday 01:28 PM
» Replies: 2
» Views: 707
Coolant leak from back of engine
Last Post: Gadgetman
Yesterday 01:18 PM
» Replies: 10
» Views: 1478

[-]
Recent Visitors
Locations of visitors to this page