Thread Rating:
  • 23 Vote(s) - 2.74 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Cooling Fan not working
#1
I need to lovcate the reason why my cooling fans does not work.
I tried to disconnect water temperature sensor and I saw that the needle of temperature mesurement in cabinet goes fully right but still fans does not comes on, I tried also turning on Air condition and the same problem.
Does anyone have electrical diagrams saw I will be able to locate the problem?
Reply
#2
Hi, try having a look at this topic
http://www.berlingoforum.co.uk/showthread.php?tid=3294
Griff
Landmark
Ex 1.4 Berlingo Multispace
Reply
#3
Is the vehicle overheating or is the gauge faulty ?
So where does this bit go then ?
Reply
#4
(15-03-2013, 09:57 AM)ffrenchie Wrote:  Is the vehicle overheating or is the gauge faulty ?

The guage is ok, Vehicle is overheating due to the fact that Fans will not start
Reply
#5
Hi, if you P/Mail me your Vin No. I'll see what I can dig out. :thumbsup:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#6
Sorry for the delay, this should be your circuit.
The coolant / AC sensor is a 4 pin blue unit (4040). The two pin green is for the egr valve. Confusedalut:

[Image: 29x7pqp.png]
2006 2.0hdi 600 with bench seat.  Cool
Reply
#7
I have replaced the 3 relays on the Fans assembly to new ones and problem is gone.
Thank you all!!!
[-] The following 2 users say Thank You to aganim for this post:
  • Ol'Jeffers, Rustscrat
Reply
#8
Nice one, thanks for letting us know. :thumbsup:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#9
(21-03-2013, 12:36 PM)Rustscrat Wrote:  Nice one, thanks for letting us know. :thumbsup:

New Problem...

I had 3 times 50A fuse blown up, It suddely burnned out and I was not able to start the engine until found this fuse under hood.
I have notticed last time that it happend imediatly after turning Air Conditioner On.
Please advise.
Thanks,
Eli.
Reply
#10
Can you tell us the number / identity of the fuse Confusedcratch: :thumbsup:
2006 2.0hdi 600 with bench seat.  Cool
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
B9 Head Unit Upgrade
Last Post: dumdum
Today 01:48 AM
» Replies: 8
» Views: 1650
wheels for a 2004
Last Post: Art b
Yesterday 09:54 PM
» Replies: 1
» Views: 151
Poor Brakes - 2006 Partner 1.6HDI Combi
Last Post: GraemeT
Yesterday 05:24 PM
» Replies: 1
» Views: 148
Fault Code P11AB???? No Turbo Assistance
Last Post: geoff
Yesterday 04:59 PM
» Replies: 2
» Views: 371
Hello from Barry
Last Post: JOP3L
Yesterday 04:54 PM
» Replies: 2
» Views: 240
Hello from Helsby
Last Post: cancunia
Yesterday 03:59 PM
» Replies: 1
» Views: 199
Recomend an inverter please
Last Post: lakeside
Yesterday 02:33 PM
» Replies: 3
» Views: 398
Permanent 12v cigarette lighter socket
Last Post: brodfather11
Yesterday 05:56 AM
» Replies: 1
» Views: 383
Berlingo 2013 double din HELP please
Last Post: Adamg78
Yesterday 05:19 AM
» Replies: 2
» Views: 355
B9 100,000 Service
Last Post: geoff
24-05-2019 11:17 PM
» Replies: 2
» Views: 410

[-]
Recent Visitors
Locations of visitors to this page