Thread Rating:
  • 3 Vote(s) - 3.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Radio help
#1
Hi,
I hope someone sees this and helps cos my wife is going mad without her radio !!!
the story so far..... radio cd player standard factory jobby. CD has always been a bit temporamental but worked on and off. However, it all suddenly stopped working. LED scree shows radio stations and volume number bass etc. CD shows track one and so on when you put cd in BUT it will not start the time count on any track, also even on radio no sound comes out whatsoever.

Please help,

cheers,

Johnnyboy.
Reply
#2
Have you tried removing it and checked the wiring is all securely fitted in place at the back?

If it is, I suspect you need a new stereo head unit.
Reply
#3
Sounds like the head unit has died but check your connections on the back first. Had to replace the unit in a ford last week with the same symptoms. If you put an aftermarket unit in have a search on the forum about connections to swap to make it work correctly. Or you could by a second hand citroen/peugeot unit that fits straight in but I think they are coded so you will need someone with lexia software to sort it for you. But I may have dreamt that last bit and someone with better brain will come along and confirm or not im sure.
Just as an update there are sellers on ebay selling head unit and offering to code the units http://www.ebay.co.uk/itm/PEUGEOT-VDO-20...3cd3199f25
Are we there yet????? Huh
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply
#4
(04-07-2013, 08:46 PM)tucker Wrote:  Have you tried removing it and checked the wiring is all securely fitted in place at the back?

If it is, I suspect you need a new stereo head unit.

Thanks checked wiring and it is ok - sounds like it has finally met it's maker !

(04-07-2013, 09:09 PM)Tomcat3 Wrote:  Sounds like the head unit has died but check your connections on the back first. Had to replace the unit in a ford last week with the same symptoms. If you put an aftermarket unit in have a search on the forum about connections to swap to make it work correctly. Or you could by a second hand citroen/peugeot unit that fits straight in but I think they are coded so you will need someone with lexia software to sort it for you. But I may have dreamt that last bit and someone with better brain will come along and confirm or not im sure.
Just as an update there are sellers on ebay selling head unit and offering to code the units http://www.ebay.co.uk/itm/PEUGEOT-VDO-20...3cd3199f25

Thanks, checked wiring - I think it is going to have to go to the radio graveyyard !
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Number plate lights staying on.
Last Post: Gordon Taylor
Yesterday 08:45 PM
» Replies: 4
» Views: 310
handbrake travel and wheels fitment
Last Post: rapidyellow
Yesterday 07:13 PM
» Replies: 2
» Views: 449
2016 berlingo 1.6 hdi oil change time
Last Post: jj9
Yesterday 06:26 PM
» Replies: 27
» Views: 2434
P0115 fault
Last Post: Dizzydave
Yesterday 03:42 PM
» Replies: 0
» Views: 172
berlingo clutch pedal play
Last Post: cancunia
Yesterday 01:01 PM
» Replies: 19
» Views: 15396
Old member returning
Last Post: Yorkshire Bling
Yesterday 10:53 AM
» Replies: 3
» Views: 500
Just bought a 1.6HDi - a few questions
Last Post: cancunia
Yesterday 07:03 AM
» Replies: 3
» Views: 386
Dip beam level adjustment motor
Last Post: Blackshuck
Yesterday 05:55 AM
» Replies: 3
» Views: 571
where did they go ?
Last Post: ajcommercial
20-08-2018 11:06 PM
» Replies: 8
» Views: 830
Random beep
Last Post: ajcommercial
20-08-2018 10:39 PM
» Replies: 4
» Views: 633

[-]
Recent Visitors
Locations of visitors to this page