Thread Rating:
  • 9 Vote(s) - 2.22 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Electrical Problem (radio & washer pump)
#1
Hi

I have an electrical fault on my 2.0 04 plate Berlingo.

The interior lights seem to have a mind of their own.
The radio doesn't switch on although you can hear it do something!!
The front and rear washer pumps don't work either.

All other electrics work fine.....windows, dash lights, clock, exterior lights etc.

Any idea's?

Many Thanks in advance
Reply
#2
Check the fuses!
Reply
#3
^^^ What he said!

Ideally replace any suspect ones with new as breaks are occasionally not obvious visually.

There should be a page in the manual identifying the relevant fuses for the various functions. If you don't have the specific manual for your car there are various ones to download here on the forum. Note the fuse diagram in the Haynes manual isn't accurate for all models - it isn't for e.g. my 2003 1.6 petrol - so refer to the car manual if available.

I suspect that'll cure the washers and radio at least...
Reply
#4
Sorry for some reason it missed off that i had actually checked the fuses as it would obviously be the first place to check!

Replaced the fuses as per manual but still no joy. Doesn't explain the dodgy interior lights :brickwall:
Reply
#5
Where did you replace fuses?
BSI, BSM or PCF?

Please read this and try to understand what's written in post:

http://www.berlingoforum.co.uk/showthread.php?tid=804
Reply
#6
Is it an original fit radio, or an aftermarket unit ?
53 plate 1.9d Multispace Forte

Upgraded t'wireless and front speakers, loads more planned but not much action.. Wink
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
1.6HDi - acceptable play on turbo shaft?
Last Post: cancunia
Today 04:16 PM
» Replies: 0
» Views: 6
Corrosion on a B9?
Last Post: Lighty
Today 02:26 PM
» Replies: 8
» Views: 614
Cheap Berlingo Multi space
Last Post: Lighty
Today 02:09 PM
» Replies: 3
» Views: 44
Berlingo 1.6 hdi bad knocking/tapping
Last Post: Mighty
Today 11:14 AM
» Replies: 7
» Views: 298
Recommend Socket Set
Last Post: evdama
Today 10:40 AM
» Replies: 6
» Views: 863
Indicator keeps blinking
Last Post: evdama
Today 10:37 AM
» Replies: 1
» Views: 218
Old member returning
Last Post: ffrenchie
Today 06:56 AM
» Replies: 2
» Views: 247
Wiring Diagram Berlingo M59
Last Post: Zion
Today 05:25 AM
» Replies: 1
» Views: 236
Cranks won't start no smoke
Last Post: Zweli
Yesterday 07:02 PM
» Replies: 2
» Views: 477
boot/trunk light not working
Last Post: densortefane
Yesterday 02:57 PM
» Replies: 1
» Views: 271

[-]
Recent Visitors
Locations of visitors to this page