Thread Rating:
  • 3 Vote(s) - 2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
speedo cluster help
#1
Hi all am new to the forum since purchasing a berlingo 1.8 multispace
2000 x reg
I have a problem with my speedo cluster

The car says it has done 0000000 miles. and the speedo and the rev gauge are not working,also when you press the trip button the whole unit shuts down and restarts.any help would be gratefully recived also if there is anyone in the leicester / hinckley area witha lexia 3 i would happily pay for the car to be read to save me going to the stealers thnaks in advance

peter
Reply
#2
Hi, It sounds like there is a failure of the Comms line between the Bsi and the cluster. Do any of the warning lights appear when you switch on the ignition? Could be something simple like the connector at the back of the unit has come adrift?
2006 2.0hdi 600 with bench seat.  Cool
Reply
#3
the dash comes on as soon as you open the door then will start beeping and flashing stop then the handbrake warning light will stay on it still does the checks of the airbag ect then they all go out
Reply
#4
(13-10-2013, 04:08 PM)peted Wrote:  the dash comes on as soon as you open the door then will start beeping and flashing stop then the handbrake warning light will stay on it still does the checks of the airbag ect then they all go out

Hi, try taking the instrument cluster out and see if it restores functionality. You will have to take the middle vents out by removing the 3 torx screws, take out the radio, then the other torx screws holding the black trim in place. Then there are 4 more torx holding the instrument cluster in place. Let me know if this helps. Thanks Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
new mot
Last Post: cancunia
Today 06:56 AM
» Replies: 10
» Views: 967
Disc pads.
Last Post: dunc391
Today 06:46 AM
» Replies: 5
» Views: 247
Forum newb slightly cheating...
Last Post: Gadgetman
Yesterday 10:09 PM
» Replies: 3
» Views: 269
Front seat and trim around handbrake and gear kn...
Last Post: Gadgetman
Yesterday 09:55 PM
» Replies: 1
» Views: 219
Bypassed shunt fuse problem
Last Post: Gadgetman
Yesterday 09:33 PM
» Replies: 2
» Views: 270
Seat Belt
Last Post: V6BOY
Yesterday 07:58 AM
» Replies: 0
» Views: 188
Engine Fault Light On With On Screen Warning Aft...
Last Post: Luis Rosa
Yesterday 05:00 AM
» Replies: 30
» Views: 3093
Dingo - 05 - 2.0 HDI
Last Post: jj9
21-05-2018 09:53 PM
» Replies: 63
» Views: 11571
Rear door
Last Post: Gravity
21-05-2018 07:28 PM
» Replies: 3
» Views: 578
Cruise control (again), yes again, but working (...
Last Post: Collapsedsuspension
21-05-2018 10:09 AM
» Replies: 96
» Views: 7548

[-]
Recent Visitors
Locations of visitors to this page