Thread Rating:
  • 11 Vote(s) - 3.45 Average
  • 1
  • 2
  • 3
  • 4
  • 5
roof bars
#1
Hi , I,m having a problem with my Roof bars (citroen) , they will no longer adjust and therefore can,t be tightened . I,ve tried wd40 with no effect , help .
Reply
#2
a bit of gentle warm heat to expand metals, might work.....
2010 artic silver VTR with EXTRAS.......Confusedunny:
Reply
#3
Try a search.
Reply
#4
http://www.berlingoforum.co.uk/showthread.php?tid=807

The Citroen ones seem like they're prone to seizing up. I've now got some AIKO ones too and will try to get round to writing up a comparative review soon.
Reply
#5
Thanks , the Citroen roof bars have a plastic casing around them so it,s hard to get at the workings inside to apply heat . I wonder if anyone has disassembled one to fix it .
Reply
#6
Yup I have. I had to drill out the remains of one of the bolts after it broke off. Basically you do need to undo the bolts (or break them off) to get it apart. Until you do there's no real way to access the bit that's rusted up (i.e. where the bolt screws into a cross-plate in the bar)

Will try to put up some pics of one disassembled at the weekend.
Reply
#7
(08-06-2011, 06:51 PM)shedpete Wrote:  Yup I have. I had to drill out the remains of one of the bolts after it broke off. Basically you do need to undo the bolts (or break them off) to get it apart. Until you do there's no real way to access the bit that's rusted up (i.e. where the bolt screws into a cross-plate in the bar)

Will try to put up some pics of one disassembled at the weekend.

That would be interesting to see , thanks .
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
boot/trunk light not working
Last Post: densortefane
Today 02:57 PM
» Replies: 1
» Views: 115
Corrosion on a B9?
Last Post: magoo
Today 02:43 PM
» Replies: 6
» Views: 364
Stereo/CD up-grade?
Last Post: Sumo278
Today 01:28 PM
» Replies: 2
» Views: 598
Coolant leak from back of engine
Last Post: Gadgetman
Today 01:18 PM
» Replies: 10
» Views: 1332
Rear wiper working from indicator stalk
Last Post: TioPotz
Today 10:16 AM
» Replies: 0
» Views: 86
Hi everybody
Last Post: polar
Today 07:56 AM
» Replies: 1
» Views: 127
Cranks won't start no smoke
Last Post: brodfather11
Yesterday 09:05 PM
» Replies: 1
» Views: 242
I love my Berlingo
Last Post: Zweli
Yesterday 07:57 PM
» Replies: 3
» Views: 498
Oil on top of engine
Last Post: Gravity
Yesterday 05:16 PM
» Replies: 7
» Views: 533
timing belt failure
Last Post: Tree
Yesterday 02:25 PM
» Replies: 9
» Views: 1023

[-]
Recent Visitors
Locations of visitors to this page