Thread Rating:
  • 8 Vote(s) - 3.13 Average
  • 1
  • 2
  • 3
  • 4
  • 5
electrical
#1
Hey all, just bought an 03 berlingo last week. I now have a few problems with the electrics. The front and rear side lights don't work along with the reverse light, fog light, the radio sounds like its been sucking on helium and when I turn on the ignition the rear wipers go on for a sec then stop. And yes I've done all the usual bulb and fuse checking, I've even soft booted the BSi but no luck. My guess is its the BSi goen bad but if anyone has any other ideas or tricks I can try, let me know. thanks.
Reply
#2
Possibly the COM2000 unit (wiper/light stalks). I have a similar problem where my wipers have a mind of their own and once on I can´t switch them off.
How much is the fish?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
FK Lowering kit actual drop
Last Post: dumdum
Today 12:46 PM
» Replies: 5
» Views: 507
Lowering fun
Last Post: northroadycles
Today 11:12 AM
» Replies: 11
» Views: 1381
Plug phone into stereo?
Last Post: LukeLog
Today 10:27 AM
» Replies: 6
» Views: 745
Modutop Door Hinges - Cable tie repair
Last Post: ghost123uk
Today 09:14 AM
» Replies: 12
» Views: 7643
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: ffrenchie
Today 09:00 AM
» Replies: 627
» Views: 123060
How Often Does AC Need Re-Gassing?
Last Post: cancunia
Today 08:51 AM
» Replies: 18
» Views: 1877
Loose connectors under dash
Last Post: brodfather11
Today 07:18 AM
» Replies: 1
» Views: 263
How did the Berlingo get it's name ?
Last Post: hawaiianblue
Yesterday 05:30 PM
» Replies: 14
» Views: 2589
Full 1.9D Van Spares
Last Post: TONX
Yesterday 04:45 PM
» Replies: 2
» Views: 445
new vehicle
Last Post: brodfather11
Yesterday 02:51 PM
» Replies: 7
» Views: 3159

[-]
Recent Visitors
Locations of visitors to this page