Thread Rating:
  • 4 Vote(s) - 2.75 Average
  • 1
  • 2
  • 3
  • 4
  • 5
cable clutch mk 1 berlingo
#1
took my x reg berlingo on a 320 mile round trip about 80 miles in found it near impossible to select first and was forcing in 2nd to move off after doing 200 miles and when I reached my destination I pushed the clutch all the way down then it sprang back and I had a clutch pedal level with the brake again and could easily select all gears

Anyone know what's wrong??
Reply
#2
My first guess would be sticking clutch cable/linkage
Landmark
Ex 1.4 Berlingo Multispace
Reply
#3
its an lpg van runs well on gas. Trying to work out what kinda mpg I'm getting should be saving 40 % of what I get on petrol
Reply
#4
Check the auto adjuster.Confusedalut:
Strawberry flavoured windows  Dodgy
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
2009 B9 Multispace recently bought
Last Post: Zion
Today 06:50 AM
» Replies: 2
» Views: 59
Front Seats 2004 multispace.
Last Post: Zion
Today 06:45 AM
» Replies: 3
» Views: 64
Vehicle tax
Last Post: John Bilko
Today 12:07 AM
» Replies: 10
» Views: 331
Missing center console, alternatives?
Last Post: Matt Haigh
Yesterday 11:14 PM
» Replies: 2
» Views: 96
Turn signal and headlights short circuit
Last Post: saskak
Yesterday 04:50 PM
» Replies: 3
» Views: 80
throttle position sensor
Last Post: Zion
Yesterday 03:45 PM
» Replies: 5
» Views: 84
New
Last Post: Zion
Yesterday 02:43 PM
» Replies: 1
» Views: 45
Annoying...
Last Post: Zion
Yesterday 02:42 PM
» Replies: 6
» Views: 151
Roof rails for k9 2022
Last Post: OlliL86
Yesterday 12:52 PM
» Replies: 20
» Views: 688
Tow bar connector
Last Post: deejay_xb
Yesterday 10:49 AM
» Replies: 1
» Views: 57

[-]
Recent Visitors
Locations of visitors to this page

[-]
Hosting by

QuickHostUK