Thread Rating:
  • 14 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Very busy maintenance sunday!
#1
Successful but very busy Sunday!

Cambelt & Tensioner
Waterpump
Thermostat
Idle speed thermostat
Coolant flush and change
Air filter
Fuel filter
Oil and filter (no sump plug disasters)
New 'brighter' headlight lamps

Sent from my GT-I9000 using Tapatalk
1.9d Mk2 (M59/BE4/5) with battle scars from a conservatory attack. Previously owned a 1.4i Mk2 Forte.Confusedalut:
Reply
#2
Hi!
And what about mileage?
Reply
#3
You should get your own stamp for the service book :thumbsup:

Good job mate
Want Help with the Forum? Read Help Documents Here

Reply
#4
Wow, that is impressive!!
2010 Berlingo Multispace HDi 110 with FAP.  Persamos green.

Reply
#5
(20-06-2011, 12:25 PM)Andre Wrote:  You should get your own stamp for the service book :thumbsup:

Good job mate

Andre. Let's make our own stamp, i.e. stamp of our club. And then try to get an authorization of PSA only for Berlingo? Smile
Reply
#6
112500 miles. Had a cambelt at 85000 ish which was fitted by the previous owners (family member) local garage. However like a bunch of tossers the pulley or tensioner wasn't changed. I did notice that there was a fair amount of play in the idler pulley bearing so pleased I changed it. I always replace cambelt kit when I get a new car for peace of mind. Mind you I've had this one for 8 months. Not worth not doing water pump for what it costs. As the coolant had to come out did thermostat as well and I needed to do the idle speed thermostat which was knackered and meant tick over was very low when cold.

Sent from my GT-I9000 using Tapatalk
1.9d Mk2 (M59/BE4/5) with battle scars from a conservatory attack. Previously owned a 1.4i Mk2 Forte.Confusedalut:
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
boot/trunk light not working
Last Post: densortefane
Today 02:57 PM
» Replies: 1
» Views: 115
Corrosion on a B9?
Last Post: magoo
Today 02:43 PM
» Replies: 6
» Views: 365
Stereo/CD up-grade?
Last Post: Sumo278
Today 01:28 PM
» Replies: 2
» Views: 599
Coolant leak from back of engine
Last Post: Gadgetman
Today 01:18 PM
» Replies: 10
» Views: 1335
Rear wiper working from indicator stalk
Last Post: TioPotz
Today 10:16 AM
» Replies: 0
» Views: 87
Hi everybody
Last Post: polar
Today 07:56 AM
» Replies: 1
» Views: 128
Cranks won't start no smoke
Last Post: brodfather11
Yesterday 09:05 PM
» Replies: 1
» Views: 243
I love my Berlingo
Last Post: Zweli
Yesterday 07:57 PM
» Replies: 3
» Views: 498
Oil on top of engine
Last Post: Gravity
Yesterday 05:16 PM
» Replies: 7
» Views: 533
timing belt failure
Last Post: Tree
Yesterday 02:25 PM
» Replies: 9
» Views: 1023

[-]
Recent Visitors
Locations of visitors to this page