Thread Rating:
  • 22 Vote(s) - 2.82 Average
  • 1
  • 2
  • 3
  • 4
  • 5
My Berlingo 2.0 HDI (new to forum)
#1


Hi everyone my name is matt and i am 25 from Rotherham in South Yorkshire, i have recently bought a 2004 (04) Berlingo 2.0 HDI and stumbled across this forum so i had to join.

i have took a few pics of my car to show you all and had a few things done to it but want to do more but cant really decide what.

please let me know what you think also i been looking at chrome add ons for the handles and wing mirrors etc does anyone have them on here or are the a bit tacky, i just wanted to make mine a bit different to others.

so far i have had the following added on

Tinted Rear windows
Rear Bumper Guard in Black
Installed Amp/Sub woofer
Installed a Sonichi SB50 Dab/Bluetooth Radio
Installed a Viper 480XV Thatcham Cat 1 Alarm
Installed Tow bar and electrics

i am wanting some front window deflectors as anyone got any and are they any good before i go ahead and buy some.

cheers Matt.

[Image: 23h6tsi.jpg]

[Image: 2en92c3.jpg]

[Image: w0omtx.jpg]

[Image: zvu3d1.jpg]

[Image: 2hfoob8.jpg]

[Image: 2rgknxy.jpg]

[Image: m9vt4o.jpg]
Reply
#2
Nice ride...I like it...

To bad that you dont have AC Confusedunny:

where did you bouht Rear Bumper Guard in Black ???
I can not find it in croatia
Reply
#3
Hi Matt and welcome to the forum. Great looking ride you got for yourself.

Tom
2010 Berlingo Multispace HDi 110 with FAP.  Persamos green.

Reply
#4
Hi Darius,

sometimes i wish i did have air-con but our british summer doesnt last long enough to have it lol, i got the bumper gaurd off ebay it screws and sticks into place and is specific for this car although it did cost £47 which is a little expensive for a bit of plastic but at least it saves my bumper from getting scratched.
hi 3rensho,

Thanks for your comment, you got any ideas for any further mods etc.
Reply
#5
Hi Matt and welcome to the forum. The windows look good, especially against the red body colour. The rear bumper guard also sits well with the black/red.

Did you fit the stereo yourself? Plenty of members on here have had mixed results with trying to upgrade
2005 Berlingo Multispace 1.6i Desire (Iron Grey)

If everything seems to be going well, you have obviously overlooked something.


Reply
#6
Hi Chris,
Yeah i have fitted it myself did have problem at first with the radio not holding pre-sets but you just have to swap red and yellow wires around although i do have to switch the stereo off when i leave the car as it doesnt switch off straight away because of the BSi ecu, if i dont switch it off it will shut itself downt after about 30 seconds of locking the door as the BSi unit shuts the power down but then when i open it up next time the radio comes on automatically.

i havent found it to be a problem i had same fault with a citroen xsara before and i believe you have to take car to dealer for the bsi ecu to be programmed so that it thinks the radio isnt there or so i been told.

and also i like the red and black look its my third darkish red car and love it when polished and clean lol
Reply
#7
Looking good!!
I DO MISS MY BERLINGO Heart
Reply
#8
Thanks Philip
Reply
#9
Very nice, look forward to seeing your next set of mods!
http://www.superiorvaleting.net
"from mild to wild"
Reply
#10
Thanks RB WRX have you any ideas of what i could do next.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Old member returning
Last Post: jj9
Yesterday 09:27 PM
» Replies: 1
» Views: 95
Wiring Diagram Berlingo M59
Last Post: CitroenC5
Yesterday 08:12 PM
» Replies: 0
» Views: 105
Berlingo 1.6 hdi bad knocking/tapping
Last Post: Mighty
Yesterday 08:07 PM
» Replies: 0
» Views: 99
Indicator keeps blinking
Last Post: Zweli
Yesterday 07:28 PM
» Replies: 0
» Views: 101
Cranks won't start no smoke
Last Post: Zweli
Yesterday 07:02 PM
» Replies: 2
» Views: 406
Recommend Socket Set
Last Post: Hardnut
Yesterday 05:25 PM
» Replies: 5
» Views: 784
Corrosion on a B9?
Last Post: V6BOY
Yesterday 04:22 PM
» Replies: 7
» Views: 531
boot/trunk light not working
Last Post: densortefane
Yesterday 02:57 PM
» Replies: 1
» Views: 241
Stereo/CD up-grade?
Last Post: Sumo278
Yesterday 01:28 PM
» Replies: 2
» Views: 701
Coolant leak from back of engine
Last Post: Gadgetman
Yesterday 01:18 PM
» Replies: 10
» Views: 1467

[-]
Recent Visitors
Locations of visitors to this page